Checkboxes aren't rendered properly inside a div with opacity

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

1.50 MB, video/ogg
Details
227 bytes, text/html
Details
(Reporter)

Description

3 years ago
Created attachment 8664113 [details]
out.ogv

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150827075926

Steps to reproduce:

Environment: fedora 22, gnome 3, firefox 40.0.3

Used HTML:

<!Doctype html>
<html>
<body>
<div style="position:absolute;right:20px; opacity:0.75">
<input type="checkbox" name="test" value="test" id="test"/>
<label for="test" > checkbox disappeared </label>
</div>
</body>
</html>



Actual results:

The checkbox disappeared or is rendered at a different place, while the checkbox stays clickable and events are fired. I recorded the behaviour and added the video as an attachement.






Expected results:

There should be a visible checkbox at the correct place!

Comment 1

3 years ago
Created attachment 8664201 [details]
1207064.html

Updated

3 years ago
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core

Comment 2

3 years ago
Surely specific to Linux.

Comment 3

3 years ago
Same with XFCE, seems not with Ubuntu 14.04 ( https://forums.mozfr.org/viewtopic.php?f=8&t=126125#p801941 )

GTK3 issue ? Must related with https://bugzilla.mozilla.org/show_bug.cgi?id=627699 ? (unsure)

Comment 4

3 years ago
Fixed in :
$ firefox -v
Mozilla Firefox 41.0

# dnf info firefox
Paquets installés
Nom         : firefox
Architectur : i686
Époque      : 0
Version     : 41.0
Révision    : 4.fc22
Taille      : 126 M
Dépôt       : @System
Depuis le d : updates
Résumé      : Mozilla Firefox Web browser
URL         : http://www.mozilla.org/projects/firefox/
Licence     : MPLv1.1 or GPLv2+ or LGPLv2+
Description : Mozilla Firefox is an open-source web browser, designed for
            : standards compliance, performance and portability.

Comment 5

3 years ago
reporter, is it fixed on your side?
Flags: needinfo?(bugzilla)
(Reporter)

Comment 6

3 years ago
Hello,

I can and will report it tomorrow. Sorry, I wasn't at work since I reported the bug.
Flags: needinfo?(bugzilla)
(Reporter)

Comment 7

3 years ago
It is fixed now.

Thanks a lot.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.