Reproducible crash when swiping back or forward

RESOLVED FIXED

Status

()

Firefox for iOS
General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kar, Assigned: rnewman)

Tracking

({crash})

unspecified
Other
iOS
crash

Firefox Tracking Flags

(fxios-v1.1 fixed, fxios-v1.0.5 ?, fxios1.1+)

Details

Attachments

(1 attachment)

48 bytes, text/x-github-pull-request
fluffyemily
: review+
Details | Review | Splinter Review
(Reporter)

Description

3 years ago
Version 1.1 (1102) on my iPhone 6 running 8.4.1

I go to a website (like m.bbc.co.uk/news/read), tap on an article, then swipe (gesture) to go back (so running my finger left-to-right).

The client crashes.

Fine if I use the back 'arrow' at the bottom. Only happens when I use the gesture.
(Assignee)

Updated

3 years ago
tracking-fxios: ? → 1.1+
Keywords: crash
Summary: reproducible crash when using gesture to go 'back' → Reproducible crash when using gesture to go 'back'
As is tradition, I am unable to reproduce this kar bug. Tried with master and 1.1 on my iPhone 6. I can swipe back fine after reading an article.

Logs/reports?
(Assignee)

Comment 2

3 years ago
I have a bunch of Breakpad crashes. Let me see if I can find them on the server.
(Assignee)

Comment 4

3 years ago
    func webView(webView: WKWebView, didFinishNavigation navigation: WKNavigation!) {
        let tab: Browser! = tabManager[webView]
        tabManager.expireSnackbars()

        if let url = webView.URL where !ErrorPageHelper.isErrorPageURL(url) && !AboutUtils.isAboutHomeURL(url) {
            tab.lastExecutedTime = NSDate.now()

            postLocationChangeNotificationForTab(tab, navigation: navigation)

fatal error: unexpectedly found nil while unwrapping an Optional value

navigation is nil in TabManagerNavDelegate.webView:didFinishNavigation: (and thus in the BVC implementation).
(Assignee)

Comment 5

3 years ago
I managed to repro that swiping *forward*, for the record.
(Assignee)

Comment 6

3 years ago
Created attachment 8664574 [details] [review]
Pull request
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
Attachment #8664574 - Flags: review?(etoop)
(Assignee)

Comment 7

3 years ago
Verified:

2015-09-22 17:02:47.373 [Warning] [BrowserViewController.swift:1517] webView(_:didFinishNavigation:) > Implicitly unwrapped optional navigation was nil.
2015-09-22 17:02:47.375 [Debug] [Profile.swift:212] onLocationChange > Recording visit for http://cariboucases.com/What-Fits-My-Bike/ with type 1.
(Assignee)

Updated

3 years ago
Summary: Reproducible crash when using gesture to go 'back' → Reproducible crash when swiping back or forward
(Reporter)

Comment 8

3 years ago
(I groaned when I saw comment 1)

If you want me to grab any of my logs, let me know which ones (and where to find them), unless Richard thinks he is confident his STR is the same bug. 

Aaron - if you go to the telegraph (www.telegraph.co.uk), tap on the first article (surprise, it's about the VW scandal), let it load completely (the progress bar finishes) and then swipe back via gesture. 

Looks like it won't reproduce if the page didn't fully load - could you be doing that?

Happens all the time on the bbc as well. Go to www.bbc.co.uk, tap on the first news article, let it load completely, then swipe back. Crash!
Comment on attachment 8664574 [details] [review]
Pull request

Is this an issue worth raising a radar over? Clearly WKNavigation is not supposed to be nil otherwise Apple wouldn't have specified the WKNavigationDelegate method to force unwrap it, but under certain circumstances it is, and the documentation never states that it should be treated as an optional despite the fact it might be.

I was only able to replicate this on my iOS 8.4 device, never on an iOS9 one so it might be a backward compatibility issue, but that's still a bug IMHO.
Attachment #8664574 - Flags: review?(etoop) → review+
(Assignee)

Comment 11

3 years ago
https://github.com/mozilla/firefox-ios/commit/3b5b111bd5476cf328213a3f5cba95589e2d8440
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-fxios-v1.0.5: --- → ?
status-fxios-v1.1: --- → fixed
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1209108
You need to log in before you can comment on or make changes to this bug.