No horizontal border between toolbar and folder pane and message pane

RESOLVED FIXED in Thunderbird 44.0

Status

Thunderbird
Theme
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: aryx, Assigned: Paenglab)

Tracking

({regression})

Trunk
Thunderbird 44.0
regression

Thunderbird Tracking Flags

(thunderbird42 unaffected, thunderbird43 affected, thunderbird44 affected)

Details

Attachments

(2 attachments, 2 obsolete attachments)

Created attachment 8664386 [details]
screenshot of issue

Thunderbird 44.0a1 20150922
(Assignee)

Comment 1

2 years ago
Aryx, on which OS is this?
Sorry, Windows 8.1 64 bit, 1.25 device pixel ratio.
(Assignee)

Comment 3

2 years ago
I see the border all the time in my 8.1 VM scaled with 100% and also 125% and 130%. Also tried with layout.css.devPixelsPerPx set to 1.25.

Do you have somewhere a style which removes the rule at https://dxr.mozilla.org/comm-central/source/mail/themes/windows/mail/primaryToolbar.css?offset=0#1940 ?
(Assignee)

Comment 4

2 years ago
Maybe we need to implement something like https://dxr.mozilla.org/mozilla-central/source/browser/themes/windows/browser.css#108
When launched in safe mode, I see the line until I select the window (is not selected, maybe because of the dialog to confirm the safe mode). Then the space between the tab and the top edge of the window widens and the line disappears.
(Assignee)

Comment 6

2 years ago
Created attachment 8664435 [details] [diff] [review]
Bug1207267.patch

Aryx, please can you try this patch if this would solve your issue?
Attachment #8664435 - Flags: feedback?(aryx.bugmail)
Comment on attachment 8664435 [details] [diff] [review]
Bug1207267.patch

Review of attachment 8664435 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, after applying the patch, the issue seems to be gone.
Attachment #8664435 - Flags: feedback?(aryx.bugmail) → feedback+
(Assignee)

Comment 8

2 years ago
Created attachment 8664464 [details] [diff] [review]
Bug1207267.patch

Thank you, Aryx. I checked the patch also under Win 7 and 10.
Assignee: nobody → richard.marti
Attachment #8664435 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8664464 - Flags: review?(philipp)
(Assignee)

Comment 9

2 years ago
Created attachment 8664786 [details] [diff] [review]
Bug1207267.patch

Added Linux and OS X using the same logic.
Attachment #8664464 - Attachment is obsolete: true
Attachment #8664464 - Flags: review?(philipp)
Attachment #8664786 - Flags: review?(philipp)
Comment on attachment 8664786 [details] [diff] [review]
Bug1207267.patch

Review of attachment 8664786 [details] [diff] [review]:
-----------------------------------------------------------------

Code looks fine to me, if the visuals are also good then this should be ok :) r=philipp
Attachment #8664786 - Flags: review?(philipp) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/303fcd96901f
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 44.0
You need to log in before you can comment on or make changes to this bug.