Cannot use markdown syntax to linkify text

VERIFIED FIXED

Status

Mozilla QA
One and Done
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

Version 3

Details

(Reporter)

Description

3 years ago
I'm unable to linkify bit.ly URLs in One & Done.

"[Click this link](http://bit.ly/1OsX2yJ)" results in the following URL:
> https://oneanddone.mozilla.org/en-US/tasks/143/a href="http://bit.ly/1OsX2yJ" rel="nofollow" http://bit.ly/1OsX2yJ</a

I can work around this by putting the URL in plain text like so:
> Click this link: http://bit.ly/1OsX2yJ
This repros the same with any link, it's not just bit.ly URLs. The editor we use requires this format. I don't know of a way to link text to a specific URL - perhaps bsilverberg will know a work around.
I tried a couple of different markdown sytnaxes which are supposed to work for links and I can confirm that they do not. We use a package called Markdown [1] to do the rendering so it might be a bug with that. I am going to try updating to the latest version (as we are on an older one) to see if that helps.

[1] https://pypi.python.org/pypi/Markdown
Summary: Cannot hyperlink bit.ly URLs → Cannot use markdown syntax to linkify text
It turns out this wasn't a problem with the package, but a bug in the code. I have fixed it in a pull request [1] which we'll try to get merged and pushed to prod soon.

[1] https://github.com/mozilla/oneanddone/pull/296
(Reporter)

Comment 4

3 years ago
Okay thanks. Let me know when it's ready and I'll retest.
Commits pushed to master at https://github.com/mozilla/oneanddone

https://github.com/mozilla/oneanddone/commit/6dbf2f91c1476d8e2f911f4ccbf03d9bdd033ccd
Fixes Bug 1207329 - Cannot use markdown syntax to linkify text

https://github.com/mozilla/oneanddone/commit/8c61eb1d18bcdd8e8d2c44dccb4659b8052acda6
Merge pull request #296 from bobsilverberg/fix_linkify

Fixes Bug 1207329 - Cannot use markdown syntax to linkify text
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

3 years ago
How long will this take to propagate to the server? I'm still seeing this issue.
Rebecca is testing it on dev and then I will push it to prod. I'll update the bug when that happens.
Verified on dev links work with updated markdown - bit.ly as well as regular URLs.
Thanks Rebecca. I have pushed the fix to staging and production as well.
Verified on prod, including https://oneanddone.mozilla.org/en-US/tasks/143/ displays correctly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.