Closed Bug 1207423 Opened 4 years ago Closed 4 years ago

Remove Apps from Tools menu

Categories

(Firefox :: Menus, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 46
Tracking Status
firefox44 --- verified
firefox45 --- verified
firefox46 --- verified

People

(Reporter: clouserw, Assigned: dao)

Details

Attachments

(2 files)

If you click the Tools menu there is an Apps option pointing at marketplace.firefox.com.  Please remove it.  See bug 1031018 for the patch that added it.
These three bugs are friends:  bug 1207422, bug 1207423, bug 1207424
Assignee: nobody → dao
Attached patch patchSplinter Review
Attachment #8704563 - Flags: review?(gijskruitbosch+bugs)
Attachment #8704563 - Flags: review?(gijskruitbosch+bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/64a9ac1e6769
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46
Attached patch patch for upliftSplinter Review
This is without they string removal since we don't need that for uplift.

Approval Request Comment
[Feature/regressing bug #]: deprecation of marketplace.firefox.com for desktop
[User impact if declined]: marketplace.firefox.com is being advertised when we don't want that
[Describe test coverage new/current, TreeHerder]:
[Risks and why]: straightforward code removal, no risk
[String/UUID change made/needed]:
Attachment #8705092 - Flags: approval-mozilla-beta?
Attachment #8705092 - Flags: approval-mozilla-aurora?
Comment on attachment 8705092 [details] [diff] [review]
patch for uplift

Makes sense, taking it. beta44+, aurora45+
Attachment #8705092 - Flags: approval-mozilla-beta?
Attachment #8705092 - Flags: approval-mozilla-beta+
Attachment #8705092 - Flags: approval-mozilla-aurora?
Attachment #8705092 - Flags: approval-mozilla-aurora+
Florin, could your team please verify this menu option is gone? Thanks!
Flags: needinfo?(florin.mezei)
Flags: qe-verify+
Flags: needinfo?(florin.mezei)
Flags: needinfo?(andrei.vaida)
Reproduced the initial issue using Aurora from 45.0a2 from 2015-01-06. Verified that the issue does not reproduce on Firefox 44 beta 7 across platforms (Windows 10 x86, Mac OS X 10.11 and Ubuntu 14.04 x64). 

Leaving qe+ as a reminder for verification on other branches.
Flags: needinfo?(andrei.vaida)
I have reproduced this bug on Nightly 44.0a1 (2015-09-22) on ubuntu 14.04 LTS, 32 bit!

The bug's fix is now verified on Latest Nightly 46.0a1!

Build ID: 20160112030227
User Agent: Mozilla/5.0 (X11; Linux i686; rv:46.0) Gecko/20100101 Firefox/46.0
QA Whiteboard: [bugday-20160113]
Status: RESOLVED → VERIFIED
Verified as fixed using Firefox 45 beta 6 under Win 7 64-bit, Ubuntu 14.04 64-bit and Mac OS X 10.9.5.
You need to log in before you can comment on or make changes to this bug.