Raytrace regression on August 13th, 2015

RESOLVED WONTFIX

Status

()

Core
JavaScript Engine
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: h4writer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
(Reporter)

Comment 1

3 years ago
A regression/improvement was reported on AWFY:
On slave: Mac OS X 10.10 (Mac Pro, browser) with mode: Ion
- jetstream: 3d-raytrace: -5.82% (regression)
- ss: 3d-raytrace: 1.79% (regression)

On slave: Win 8 32-bit (i7-4700HQ, browser) with mode: Ion, PGO
- dromaeo: sunspider-3d-raytrace: -6.28% (regression)

On slave: Win 8 32-bit (i7-4700HQ, browser) with mode: Ion
- dromaeo: sunspider-3d-raytrace: -8.56% (regression)

On slave: Mac OS X 10.10 32-bit (Mac Pro, shell) with mode: Ion
- ss: raytrace: 5.83% (regression)

Combined regression range:
- http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0cf9bfd5af47ed565d31694c9dae1fb879a7423f&tochange=1a059d75e3adf63fd4a9aba963c86db2ddaddb95

=> I would think this is bug 1194148. Where we selfhosted toArray.

More info on:
https://arewefastyet.com/regressions/#/bug/1207467

@jandem: setting needinfo to let you know and decide how we to carry on. I think this is some perturbation caused by the selfhosting patch, but this is sunspider-like tests, where a small change in compilation can cause some knock-on effect. But we don't see this regression on its big brother octane-raytrace. Since ss is not that important I would have no problem marking this as wontfix.
Blocks: 1194148
Flags: needinfo?(jdemooij)
(Reporter)

Comment 2

3 years ago
@jandem: anything you want to test/double check before ruling this is wontfix?
Yeah I wasn't able to reproduce this back then and it should improve performance actually, see bug 1194148 comment 5.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(jdemooij)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.