Closed Bug 1207527 Opened 6 years ago Closed 6 years ago

[v2.5][Gaia::UI Tests]test_settings_wallpaper.py:"NoSuchElementException: NoSuchElementException: Unable to locate element: .wallpaper'"

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1208639

People

(Reporter: xiongfuchao, Unassigned)

References

()

Details

Attachments

(1 file)

[Description]
test_settings_wallpaper.py fails

[Steps to Reproduce]
test_settings_wallpaper.py

[Reproduction Frequency]
Always, 5/5

Traceback (most recent call last):
  File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.non-smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_client-0.17-py2.7.egg/marionette/marionette_test.py", line 296, in run
    testMethod()
  File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.non-smoketest/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_wallpaper.py", line 22, in test_change_wallpaper
    activities_menu = display_settings.pick_wallpaper()
  File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.non-smoketest/tests/python/gaia-ui-tests/gaiatest/apps/settings/regions/display.py", line 36, in pick_wallpaper
    self.marionette.find_element(*self._wallpaper_pick_locator).tap()
  File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.non-smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_driver-0.13-py2.7.egg/marionette_driver/marionette.py", line 1579, in find_element
    el = self._send_message("findElement", body, key="value")
  File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.non-smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_driver-0.13-py2.7.egg/marionette_driver/decorators.py", line 36, in _
    return func(*args, **kwargs)
  File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.non-smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_driver-0.13-py2.7.egg/marionette_driver/marionette.py", line 711, in _send_message
    self._handle_error(resp)
  File "/var/lib/jenkins/workspace/B2G.master.PVT.FlameKK.gaiatest.non-smoketest/tests/python/gaia-ui-tests/.env/local/lib/python2.7/site-packages/marionette_driver-0.13-py2.7.egg/marionette_driver/marionette.py", line 752, in _handle_error
    raise errors.lookup(error)(message, stacktrace=stacktrace)
NoSuchElementException: NoSuchElementException: Unable to locate element: .wallpaper

[Build info]
Device firmware (base)	L1TC000118D0
Device firmware (date)	22 Sep 2015 18:32:55
Device firmware (incremental)	eng.cltbld.20150922.063242
Device firmware (release)	4.4.2
Device identifier	flame
Gaia date	21 Sep 2015 17:27:10
Gaia revision	29991414eb94
Gecko build	20150922030227
Gecko revision	2235e56c94cf61614902fd3a4ac7b837f7154b97
Gecko version	44.0a1

[Attachments]
2015-09-23-12_Non-Smoketest.html
It seems there is no option to pick the wallpaper anymore in in display settings.  	
Guillaume, is this something that could be fixed by bug 1206272?
Flags: needinfo?(gmarty)
Bug 1206272 is fixed, but I can still reproduce this issue in:
Build ID               20150923150203
Gaia Revision          8472f0c736660072799aaae60e4b6001a6aaceb4
Gaia Date              2015-09-23 10:29:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4a46de29431baa621d98d8f1168e43297ce1a916
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150830.021652
Firmware Date          Sun Aug 30 02:17:03 EDT 2015
Bootloader             L1TC000118D0
Component: Gaia::UI Tests → Gaia::Homescreen
Depends on: 1208639
Flags: needinfo?(gmarty)
No longer depends on: 1208639
Depends on: 1208639
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1208639
You need to log in before you can comment on or make changes to this bug.