Closed Bug 1207550 Opened 5 years ago Closed 4 years ago

Bookmark or Downloads window stay in fullscreen mode on Mac OS X

Categories

(Core :: Widget: Cocoa, defect)

41 Branch
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: papin.alexandre, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image 2015-09-23 at 13.28.png
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150917150946

Steps to reproduce:

On Mac OS X, start a refresh copy of firefox.

Go in fullscreen mode (cmdf + alt + f)

Display the Bookmarks or Downloads window.

The window displays in another fullscreen window.

Close the window.

Re-open the Bookmarks or Downloads window


Actual results:

The Bookmarks or Downloads window is displayed on top of the fullscreen firefox window, not a new window.

If I exit fullscreen mode for firefox and display Bookmarks or Downloads window, it is displayed on top of the screen like in fullscreen with no buttons to close the window.


Expected results:

The Bookmarks or Downloads window should be displayed in seperate fullscreen window (when in fullscreen mode) or displayed in non-fullscreen window (when in normal mode)
Component: Untriaged → Widget: Cocoa
Product: Firefox → Core
Thanks for reporting this problem and including a screen shot.

I'm not sure I understand the problem. Here are the keyboard shortcuts I am using to test:

1. Go fullscreen using CMD+SHIFT+F
2. Open Downloads window with CMD+J -> The Downloads window opens but it is not a fullscreen window.
3. Close Downloads window with ESC
4. Reopen Downloads window with CMD+J -> The Downloads window opens but it is not a fullscreen window.
5. Close Downloads window again with ESC
6. Exit fullscreen using CMD+SHIFT+F
7. Reopen Downloads window with CMD+J -> The Downloads window opens but it is not a fullscreen window.
Hum.. Maybe it's an issue with OS X El Capitan but I had this problem with Yosemite too..

Your steps are clearer.

1. Go fullscreen using CMD+CTRL+F or CMD+SHIFT+F
2. Open Downloads window with CMD+J -> The Downloads window opens in a fullscreen window.
3. Close Downloads window with CMD+W (ESC does not close the window for me)
4. Reopen Downloads window with CMD+J -> The Downloads window overlaps the firefox fullscreen window.
5. Close Downloads window again with CMD+W (ESC does not close the window for me)
6. Exit fullscreen using CMD+CTRL+F or CMD+SHIFT+F
7. Reopen Downloads window with CMD+J -> The Downloads window opens and overlaps firefox window exactly same way as in fullscreen.

If you don't have the same problem as me on step 4 maybe this is an isolated bug on OS X.11 GM.

I'll try again when OS X El Capitan will be publicly released.

If anyone can try to be sure its just me or a real bug.
I suspect this bug should have been fixed by bug 1137009. Now, neither the download window nor the bookmark window should ever be opened in fullscreen. They should always be opened as a normal window like in normal mode.

Could you verify this behavior in the latest Nightly?
Flags: needinfo?(papin.alexandre)
(In reply to Xidorn Quan [:xidorn] (UTC+10) from comment #3)
> I suspect this bug should have been fixed by bug 1137009. Now, neither the
> download window nor the bookmark window should ever be opened in fullscreen.
> They should always be opened as a normal window like in normal mode.
> 
> Could you verify this behavior in the latest Nightly?

Good news.

With FirefoxNightly with fresh profile (otherwise it's still have same behaviour..)

1. Go fullscreen using CMD+CTRL+F or CMD+SHIFT+F
2. Open Downloads window with CMD+J -> The Downloads window opens in a fullscreen window.
3. Close Downloads window with CMD+W (ESC does not close the window for me)
4. Reopen Downloads window with CMD+J -> The Downloads window opens in a fullscreen window.
5. Exit fullscreen using CMD+CTRL+F or CMD+SHIFT+F (Keep Downloads window open in fullscreen)
6. Open Downloads window with CMD+J -> Focus switch to Download window in fullscreen.
7. Close Downloads window with CMD+W (ESC does not close the window for me)
8. Reopen Downloads window with CMD+J -> The Downloads window opens in a normal window.

So it's ok with the nightly but only with a fresh profile. I don't know where but there is something saved in the profile that keep the Downloads window in a bad state.
Flags: needinfo?(papin.alexandre)
Hi guys,

Well bad news, with Firefox 42 with a fresh profile on OS X El Capitan, the problem persists.

Is there a way to share some logs or anything that can help you ?
Bug 1137009 lands in Firefox 43, so it is expected that 42 doesn't fix this issue.
This works for me on latest Nightly 49.0a1, 20160518030234

though the download window does open in full screen (step 4 in comment 4) that comment 3 says should never happen.  that's a different bug than this was.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Hi guys,

This bug is not happening anymore since 2-3 months at least, I forgot to tell you.

Ok, the download window open in full screen when FF is in full screen but open as normal window when FF is not full screen.

So for me, everything works as expected.

Good job !
You need to log in before you can comment on or make changes to this bug.