Closed Bug 1207553 Opened 7 years ago Closed 7 years ago

Improve log reporting of application crashes with Marionette

Categories

(Testing :: Marionette, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1229765

People

(Reporter: whimboo, Unassigned)

Details

As of now Marionette is not able to correctly log a crash so that it can be seen on treeherder for a particular test. Instead you get assertions like reported on bug 1202375 which look like:

> error: [Errno 10061] No connection could be made because the target machine actively refused it
>
> AssertionError: Timed out waiting for port!

With Mozmill we set the test failure description to "Application crashed" and ignored any jsbridge related exceptions which do not really tell you what's going on.

It would be great if Marionette would do the same.

https://github.com/mozilla/mozmill/blob/master/mozmill/mozmill/__init__.py#L543
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1229765
You need to log in before you can comment on or make changes to this bug.