[Ubuntu] Glitches when scrolling on pages with Flash content

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
2 years ago
9 months ago

People

(Reporter: adalucinet, Unassigned)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(e10s-, firefox44 affected, firefox45 affected, firefox46 affected, firefox47 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Reproducible on latest 42 beta 1, latest 43.0a2 and 44.0a1 (from 2015-09-22)
Affected paltforms: 2 different Ubuntu 14.04 x32 machines

Steps to reproduce:
1. Launch Firefox.
2. Navigate to http://www.bbc.com/news/world-europe-34332759
3. Scroll down.

Expected result: Scrolling is smooth, without any jerkiness or rendering issues.
Actual result: Glitches visible.

Additional notes:
1. Issue more visible if the Bookmarks Toolbar is enabled - Screencast: https://goo.gl/qXsdHm
2. Also reproducible on Youtube if Flash is used instead of HTML5.
3. Not reproducible with 40 beta 3 nor 41.0 RC build 3.
4. Flash version: 11.2.202.521
5. Graphics section from about:support page:
Adapter Description	nouveau -- Gallium 0.4 on NVA8
Asynchronous Pan/Zoom	none
Device ID	Gallium 0.4 on NVA8
Driver Version	3.0 Mesa 10.1.3
GPU Accelerated Windows	0/2 Basic (OMTC)
Supports Hardware H264 Decoding	false
Vendor ID	nouveau
WebGL Renderer	nouveau -- Gallium 0.4 on NVA8
windowLayerManagerRemote	true
AzureCanvasBackend	cairo
AzureContentBackend	cairo
AzureFallbackCanvasBackend	none
AzureSkiaAccelerated	0
CairoUseXRender	1
I experienced a similar issue on Debian during the 42 aurora cycle. I haven't find a str
I was also able to reproduce this issue while scrolling on http://www.dailymotion.com/video/x3qq2se_11-artists-who-shockingly-don-t-have-grammys_news

This issue is reproducible only with e10s enabled on Firefox 45 beta 3 (with multi-process experiment enabled), Firefox 46.0a2 (2016-02-08) and Firefox 47.0a1 (2016-02-08) under Ubuntu 12.04 32-bit.
status-firefox45: --- → affected
status-firefox46: --- → affected
status-firefox47: --- → affected
Hardware: x86 → All
Summary: [Ubuntu] Glitches when scrolling on pages with Flash content → [Ubuntu][e10s] Glitches when scrolling on pages with Flash content
(In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #0)
> 2. Also reproducible on Youtube if Flash is used instead of HTML5.

Are you seeing this with HTML5 youtube videos or just flash?
Flags: needinfo?(alexandra.lucinet)
(In reply to George Wright (:gw280) (:gwright) from comment #3)

> Are you seeing this with HTML5 youtube videos or just flash?

- This issue is *not* reproducible for HTML5 youtube videos.

- We managed to reproduce these glitches on youtube only if flash is used instead of HTML5. This is possible with YouTube Flash Player add-on installed, that allows you to watch YouTube videos using Flash Player instead of the default HTML5 player. (https://addons.mozilla.org/en-US/firefox/addon/youtube-flash-player/?src=search)
Flags: needinfo?(alexandra.lucinet)

Updated

2 years ago
Flags: needinfo?(jmathies)

Comment 5

2 years ago
Plugin windows should be hidden when scrolling. I don't see how this is happening, do you have the debug pref 'gfx.e10s.hide-plugins-for-scroll' set?

I just tested on Ubuntu with latest nightly and everything looked good.
Flags: needinfo?(jmathies) → needinfo?(vasilica.mihasca)

Comment 6

2 years ago
also, are you using apz, and can you post the url of the web site you're testing with please.
Created attachment 8720750 [details]
flashglitches.ogv

I am able to reproduce this issue on Firefox 47.0a1 (2016-02-17), Firefox 46.0a2 (2016-02-17) and Firefox 45 Beta 6 with e10s enabled (browser.tabs.remote.autostart: true) under Ubuntu 12.04 64-bit scrolling on this sites:
- http://www.bbc.com/news/world-europe-34332759 (from Description)
- http://www.dailymotion.com/video/x3qq2se_11-artists-who-shockingly-don-t-have-grammys_news (from Comment 2) 

- This issue is not an APZ bug, because it is also reproducible with layers.async-pan-zoom.enabled pref set to false across all versions.
- I do not have set gfx.e10s.hide-plugins-for-scroll.
- This issue is no longer reproducible with e10s disabled.
- I am attaching a video where I captured this issue.
Flags: needinfo?(vasilica.mihasca)

Comment 8

2 years ago
(In reply to Vasilica Mihasca, QA [:vasilica_mihasca] from comment #7)
> Created attachment 8720750 [details]
> flashglitches.ogv


This is different from your original screencast where there was a clipping problem - 

Screencast: https://goo.gl/qXsdHm

Can you detail more clearly what bug(s) you're reporting?
Flags: needinfo?(alexandra.lucinet)
(Reporter)

Comment 9

2 years ago
(In reply to Jim Mathies [:jimm] from comment #8)
> (In reply to Vasilica Mihasca, QA [:vasilica_mihasca] from comment #7)
> > Created attachment 8720750 [details]
> > flashglitches.ogv
> 
> 
> This is different from your original screencast where there was a clipping
> problem - 
> 
> Screencast: https://goo.gl/qXsdHm
> 
> Can you detail more clearly what bug(s) you're reporting?

The clipping for which this report was submitted is still reproducible - checked with latest Nightly 47.0a1 (from 2016-02-22), under Ubuntu 14.04 x32, but with e10s disabled. 

Also confirming that the issue Vasilica pointed out in comment 2 and comment 7 is reproducible with Ubuntu 14.04 x32 too, *only* with e10s enabled - the best approach I guess it's for Vasilica to file a separate report.
Flags: needinfo?(alexandra.lucinet) → needinfo?(vasilica.mihasca)
Summary: [Ubuntu][e10s] Glitches when scrolling on pages with Flash content → [Ubuntu] Glitches when scrolling on pages with Flash content

Comment 10

2 years ago
Ok, thanks.
tracking-e10s: --- → -
Noticed that there is already filed a bug for the issue described in Comment 7. See Bug 1212813.
Flags: needinfo?(vasilica.mihasca)
Duplicate of this bug: 1312899
WFM on Fx 53b8, Ubuntu 16.04 x86.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WORKSFORME

Comment 14

9 months ago
This issue does exist in Firefox 52.0.1. Are you sure that this issue is fixed in Firefox 53b8? The site in the startpost looks like it has migrated to HTML5 videos so this issue can maybe not reproduced there anymore. Can you check if this issue does still exist on scrolling for example at http://www.kongregate.com/games/xdanond/rpg-shooter-starwish ?
Flags: needinfo?(paul.silaghi)
Unable to reproduce the issue in comment 0 on both 52.0.1 and 53b8.
Reproduced the issue in comment 7 on 52.0.1, unable to reproduce it on 53b8.
Ubuntu 16.04 x86, Flash v25.0.0.127.
http://www.kongregate.com/games/xdanond/rpg-shooter-starwish
Flags: needinfo?(paul.silaghi)

Comment 16

9 months ago
Thanks for the testing. On my test I was on the same flash player version too so it looks that this issue will be indeed completely fixed with Firefox 53.
You need to log in before you can comment on or make changes to this bug.