Page gives no clue how to step through code on Linux

RESOLVED WORKSFORME
(NeedInfo from)

Status

Developer Documentation
General
P1
normal
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: JVD, Unassigned, NeedInfo)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: 40 Branch
 Technical Contact: 

:: Details

Build identifier: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0 
DPKG version: 40.0.3+build1-0ubuntu0.14.04.1


The page at the URL :
     https://developer.mozilla.org/en-US/docs/Tools/Debugger/How_to/Step_through_code
is either out-of-date or MacOS specific .

When I set a breakpoint into some Javascript code in a web-page with above mozilla release on Linux ,
I see nothing like the window shown at the above URL .

There is no 'Play' ( left pointing triangle icon ? ) anywhere I can see with the developer toolbar expanded
and the debugger tab selected . 

Reloading the page after a breakpoint has been set does not result in the code being suspended at the breakpoint
when the code containing the breakpoint is entered and evaluated . 

It is very far from clear how to use any of the tools in the new 'Developer Toolbar' .

The old Javascript debugger and DOM Inspector seemed to be fairly intuitive and simple to use ,
but alas this is no longer the case, and I can't find any usable documentation for it.
What documentation there is seems to be for the MacOSX UI, and bears no resemblance to
what is seen under Linux / X-Windows (GTK) .

Can anyone suggest how to set a breakpoint in JavaScript code with the new debugger 
running on Linux and get the code to stop at the breakpoint ?
Sorry it's taken me a while to get to this.

But I don't understand the problem: the UI for the devtools in Linux is almost exactly the same as the UI for the devtools in Windows or Mac OS X. While it's true that most of the screenshots and videos are taken from OS X, they would look almost exactly the same on other platforms. Where there are differences (for example, keyboard shortcuts) we try to document them.

I've attached a screenshot of the debugger paused at a breakpoint in Ubuntu (Firefox 40/Ubuntu 12). You can see, it looks just like the screenshot on MDN. Could you attach a screenshot of what you are seeing? What do you see when you follow the instructions to open the debugger [1] (I've just tried to clarify these.)

One possible clue is: you refer to the "Developer Toolbar"[2]. But this is not the debugger: it's a different tool, that gives you a command line interface to various devtools.

[1] https://developer.mozilla.org/en-US/docs/Tools/Debugger/How_to/Open_the_debugger
[2] https://developer.mozilla.org/en-US/docs/Tools/GCLI.
Flags: needinfo?(jason.vas.dias)
Created attachment 8685636 [details]
debugger.png
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.