The email menu will flicker when the second account is selected and the user opens the account selector

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
9 months ago

People

(Reporter: AdamA, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8665070 [details]
logcat

Description:
In the email app if the user has 2 accounts signed in and with the second account selected opens the account chooser the menu will flicker and jump around.

Repro Steps:
1) Update a Aries to 20150923113746
2) Open Email app
3) Sign in 2 accounts
4) Press the three lines in the upper right to open the menu
5) Press on the email address name
6) Select the second account listed
7) Repeat steps 4-5
8) Observe screen

Actual:
The menu will flicker

Expected:
It is expected that the menu does not flicker when opening up with the second account selected.

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20150923113746
Gaia: aad942e6960cdd6b2d09900b157b16f4ddb9423c
Gecko: abe43c30d78d7546ed7c622c5cf62d265709cdfd
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 10/10
See attached: video clip, logcat
(Reporter)

Comment 1

3 years ago
This issue DOES occur on Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
BuildID: 20150923030227
Gaia: 864500d40633bbf0e9a83c92a03cea46bb901906
Gecko: 19b4265d0d568d232fb3a34705f947b6db7496dc
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Result:
The menu will flicker
------------------------------------
This issue DOES NOT occur on Flame 2.2.

Environmental Variables:
Device: Flame 2.2 [Full Flash]
BuildID: 20150923032502
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: 65ddad73ad6b
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
The menu does not flicker.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
Teri, can you take a look at this please?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker) → needinfo?(twen)
Keywords: regressionwindow-wanted

Updated

3 years ago
status-b2g-v2.2: --- → unaffected

Updated

3 years ago
QA Contact: jthomas

Comment 3

3 years ago
I could not reproduce the flicker issue on the latest master and 20150923113405.

Build ID               20150923233246
Gaia Revision          8472f0c736660072799aaae60e4b6001a6aaceb4
Gaia Date              2015-09-23 10:29:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f1dffc8682fbba463cb4bb305f293ddcccbc20b4
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150923.225204
Firmware Date          Wed Sep 23 22:52:12 UTC 2015
Bootloader             s1


Build ID               20150923113405
Gaia Revision          aad942e6960cdd6b2d09900b157b16f4ddb9423c
Gaia Date              2015-09-23 03:24:27
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/abe43c30d78d7546ed7c622c5cf62d265709cdfd
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150923.105458
Firmware Date          Wed Sep 23 10:55:05 UTC 2015
Bootloader             s1

Please check if problem still exist.
Flags: needinfo?(twen)

Updated

3 years ago
Flags: needinfo?(aalldredge)
(Reporter)

Comment 4

3 years ago
I was able to reproduce this issue today.

Environmental Variables:
Device: Aries 2.5 [Full Flash]
BuildID: 20150924111215
Gaia: 4bb17b24620818cbda0ba0c0d69e0ce3f914e1b7
Gecko: 001942e4617b2324bfa6cdfb1155581cbc3f0cc4
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
Flags: needinfo?(aalldredge)

Comment 5

3 years ago
I was unable to find a window on this bug. Sometimes after adding two Emails the user is able to reproduce this flicker issue while other times the issue does not occur whatsoever even when following the STR directly. The issue will either occur 100% after selecting the drop down menu over and over again or will not occur at all unless reflashing an unknown amount of times.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
QA Contact: jthomas

Comment 6

3 years ago
Leaving regressionwindow-wanted for now if someone else wants to attempt, however be warned. It may take at least several reflashes to see if the issue does occur or not.
The repro rate of this issue is actually too low to find a window.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
While experimenting with the folder_picker in the conversations branch for email, I applied a will-change: transform to the .fld-acct-container element and I can replicate a similar effect as the one in the video, even a bit worse.

It could mean that it points to some regression with the apz drawing or something around the optimizations that are also selected if will-change: transform is used. Perhaps without the explicit will-change, gecko sometimes chooses the same optimizations itself and that optimization exhibits this behavior.

The conversations branch is not in good enough shape to give a good test case yet, so for now just leaving this note before I forget about it.

Comment 9

9 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.