Closed Bug 1207841 Opened 4 years ago Closed 4 years ago

ARM: Clean up Imm8::EncodeImm() and friends

Categories

(Core :: JavaScript Engine: JIT, defect)

ARM
Unspecified
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1207843

People

(Reporter: sstangl, Unassigned)

Details

Attachments

(1 file)

Bug in three parts:

Part 1: Remove a bunch of dead code from ma_b().
Part 2: Fix spacing between functions in the ARM MacroAssembler.
Part 3: Rewrite Imm8::EncodeImm() to favor readability instead of micro-optimization.
Hello Sean, im unsure why i got this task assigned. :)
Comment on attachment 8665173 [details] [diff] [review]
0001-Clean-up-ma_b-void-target.patch

Review of attachment 8665173 [details] [diff] [review]:
-----------------------------------------------------------------

Wrong reviewer
Attachment #8665173 - Flags: review?(jakobdo) → review?(sstangl)
Attachment #8665173 - Flags: review?(sstangl)
This is a duplicate bug, from a time when Bugzilla froze while filing.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1207843
You need to log in before you can comment on or make changes to this bug.