Closed Bug 1207877 Opened 4 years ago Closed 4 years ago

Categories

(Firefox for Android :: Testing, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 46
Tracking Status
firefox44 --- affected
firefox45 --- fixed
firefox46 --- fixed

People

(Reporter: philor, Assigned: gbrown)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

No description provided.
Assignee: nobody → gbrown
This test loads robocop_blank_01 in a tab, then opens a second tab and loads robocop_blank_02 in that tab. Screenshots from this failure show the url bar contains "http://mochi.test:8888/tests/robocop/robocop_blank_01.htmlhttp://mochi.test:8888/tests/robocop/robocop_blank_02.html", with the first part ("http://mochi.test:8888/tests/robocop/robocop_blank_01.html") highlighted. A race between the test and a page load handler to update the url bar? Something related to search suggestions?

I cannot reproduce manually in the emulator.
testNewTab uses BaseTest.addTab(url) which is one of the few remaining clients of the ever-troublesome inputAndLoadUrl().
This just changes the way that robocop initiates a page load -- as in bug 923109 -- this time after adding a new tab. That old code to type into the url bar keeps breaking -- better to avoid it.

Try looks good, and I can even re-enable testNewTab on 4.3:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=68a706ecede3&selectedJob=15580086

I may also be able to dup several other bugs to this one: bug 995696, bug 1145851, bug 1234045.
Attachment #8709163 - Flags: review?(margaret.leibovic)
Comment on attachment 8709163 [details] [diff] [review]
in BaseTest.addTab, use loadUrlAndWait instead of inputAndLoadUrl

Review of attachment 8709163 [details] [diff] [review]:
-----------------------------------------------------------------

Nice find.
Attachment #8709163 - Flags: review?(margaret.leibovic) → review+
Duplicate of this bug: 995696
Duplicate of this bug: 1234045
Duplicate of this bug: 1145851
https://hg.mozilla.org/mozilla-central/rev/31cea552fc10
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46
You need to log in before you can comment on or make changes to this bug.