"about:" pages do not respect color overrides

RESOLVED DUPLICATE of bug 1207084

Status

()

Toolkit
Themes
RESOLVED DUPLICATE of bug 1207084
2 years ago
2 years ago

People

(Reporter: quadim, Unassigned)

Tracking

({regression})

41 Branch
regression
Points:
---

Firefox Tracking Flags

(firefox40 unaffected, firefox41- affected, firefox42-, firefox43-, firefox44-)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150918100310

Steps to reproduce:

Since Firefox 41 (as distributed by Ubuntu for the Trusty release):

Edit -> Preferences -> Content -> Colors

    Text and Background: Invert the color for "Text" and "Background" (black to
    white and vice versa)

    Override the colors...: choose "Always"

I believe his should be equivalent to setting the following preferences:

    browser.display.background_color = #000000
    browser.display.foreground_color = #FFFFFF
    browser.display.use_document_colors = false


Actual results:

Web pages actually abide by these settings and are always rendered with *black*
background and *white* foreground (text, and other elements such as borders).

However, internal pages used by firefox [1] do not "completely" respect them:
Text shows white, yet background is also white!  This makes the page unusable,
of course.

[1] Such as about:{preferences,addons,config,privatebrowsing,support}, likely
    many others.

    Some pages that "apparently" work OK are: about:{blank,newtab}.  But note
    that these pages do not contain text (I disabled the tiles in new tabs), so
    I'm not sure.


Expected results:

As in Firefox 40, both external and internal ("about" or "chrome") pages should
respect all the color override preferences set by the user.

Comment 1

2 years ago
Created attachment 8665394 [details]
colors-FF40-FF41-win7.jpg

Regressin range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ca9f095bb18cd0318938b7ebc634f27bba21a1dd&tochange=294fc78e528c217fd0c7e1bd9fc1d2687b5266ba

I suspect:
Richard Marti — Bug 1161156 - about:support: Use the new in-content styling. r=MattN
Richard Marti — Bug 1160733 - about:permissions: use the new in-content style-sheet. r=Gijs

Updated

2 years ago
Status: UNCONFIRMED → NEW
status-firefox40: --- → unaffected
status-firefox41: --- → affected
tracking-firefox41: --- → ?
tracking-firefox42: --- → ?
tracking-firefox43: --- → ?
tracking-firefox44: --- → ?
Component: Untriaged → Themes
Ever confirmed: true
Flags: needinfo?(richard.marti)
Keywords: regression
OS: Unspecified → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1207084
Flags: needinfo?(richard.marti)

Comment 3

2 years ago
Untracked here as bug 1207084 is tracked for 42+.
tracking-firefox41: ? → -
tracking-firefox42: ? → -
tracking-firefox43: ? → -
tracking-firefox44: ? → -
You need to log in before you can comment on or make changes to this bug.