Firefox hangs when closing WebIDE

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools: WebIDE
RESOLVED WONTFIX
2 years ago
6 months ago

People

(Reporter: marco, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox44 affected)

Details

Attachments

(2 attachments)

1002.88 KB, application/x-7z-compressed
Details
1.01 MB, application/x-7z-compressed
Details
(Reporter)

Description

2 years ago
When I close WebIDE, Firefox hangs. GNOME shows a dialog prompting me to close Firefox because it isn't responding.

After a while, when WebIDE gets closed, I can use Firefox again.

I can consistently reproduce this bug.

P.S.: I see another hang, shorter, when I resize the WebIDE window.
(Reporter)

Comment 1

2 years ago
Created attachment 8669954 [details]
x_1a9D2e.7z

Here's a profile.
(Reporter)

Comment 2

2 years ago
I'm seeing ~28% of the time spent in the *sync* function in http://mxr.mozilla.org/mozilla-central/source/services/sync/modules/service.js
Component: Untriaged → Sync
I'm not sure what to do with the .bin file in that profile attachment. If you set browser.dom.window.dump.enabled=true and services.sync.log.appender.dump="Trace", you should see Sync messages spewed to the console which will probably offer some clues - the fact it is 100% reproducible surprises me. Could you please try the above prefs and capture the output?
Flags: needinfo?(mar.castelluccio)
(Reporter)

Comment 4

2 years ago
(In reply to Mark Hammond [:markh] from comment #3)
> I'm not sure what to do with the .bin file in that profile attachment.

You can upload it here to see the profile:
http://people.mozilla.org/~bgirard/cleopatra/

> If you set browser.dom.window.dump.enabled=true and
> services.sync.log.appender.dump="Trace", you should see Sync messages spewed
> to the console which will probably offer some clues - the fact it is 100%
> reproducible surprises me. Could you please try the above prefs and capture
> the output?

I will try this tomorrow.
Flags: needinfo?(mar.castelluccio)
(Reporter)

Updated

2 years ago
Flags: needinfo?(mar.castelluccio)
That profile is showing we are indeed uploading history records as part of a Sync. I *hope* this was fixed in bug 1195603 (which landed in 43) but the info I asked for above should be able to tell me either way.
(In reply to Mark Hammond [:markh] from comment #5)
> I *hope* this was fixed in bug 1195603 (which landed in 43)

Bugger - it looks like this was reported against 44, so apparently not :(
(Reporter)

Comment 7

2 years ago
Created attachment 8670376 [details]
v7WEtcTN.7z

This second profile isn't related to Sync.
The common function between the two profiles is "PollWrapper" (in this second profile, > 60%).
Flags: needinfo?(mar.castelluccio)
Flags: firefox-backlog+
Marco, it sounds like this isn't related to Sync, so it sounds like we should put it back into the WebIDE category until we have more ideas?
Flags: needinfo?(mar.castelluccio)
(Reporter)

Comment 9

2 years ago
Yes, totally agree.
Component: Sync → Developer Tools: WebIDE
Flags: needinfo?(mar.castelluccio)
Marco, can you share the source of the project you have open in WebIDE?

Does it have a lot of files?

It looks like we may be spending a lot of clearing out the file tree, so we should optimize that if true.
Flags: needinfo?(mar.castelluccio)
(Reporter)

Comment 11

2 years ago
(In reply to J. Ryan Stinnett [:jryans] (use ni?) from comment #10)
> Marco, can you share the source of the project you have open in WebIDE?
> 
> Does it have a lot of files?
> 
> It looks like we may be spending a lot of clearing out the file tree, so we
> should optimize that if true.

This is likely the culprit. I've removed the projects from the list and now it doesn't hang anymore.
To reproduce again, I just need to re-add a directory with a lot of files.
Flags: needinfo?(mar.castelluccio)
(In reply to Marco Castelluccio [:marco] from comment #11)
> (In reply to J. Ryan Stinnett [:jryans] (use ni?) from comment #10)
> > Marco, can you share the source of the project you have open in WebIDE?
> > 
> > Does it have a lot of files?
> > 
> > It looks like we may be spending a lot of clearing out the file tree, so we
> > should optimize that if true.
> 
> This is likely the culprit. I've removed the projects from the list and now
> it doesn't hang anymore.
> To reproduce again, I just need to re-add a directory with a lot of files.

Are you able to mention the projects you had?  This would help me do a meaningful perf comparison with what you're seeing.
Flags: needinfo?(mar.castelluccio)
(Reporter)

Comment 13

2 years ago
I had a folder containing three subfolders: https://github.com/marco-c/watchy, https://github.com/marco-c/watchy/tree/gh-pages, https://github.com/mozilla/high-fidelity.
Flags: needinfo?(mar.castelluccio)
WebIDE triage. Filter on TRIAGE-JD201705

This is related app development in WebIDE, which is going to be removed. Closing as wontfix.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.