reduce the default timeout inside of mochitest from 300 seconds to 60 seconds

RESOLVED DUPLICATE of bug 1212051

Status

Testing
Mochitest
RESOLVED DUPLICATE of bug 1212051
2 years ago
2 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fail_faster][productivity_roadmap])

(Reporter)

Description

2 years ago
to help us fail faster instead of wasting machine resources during  a timeout, we should reduce our default time to wait for a failure.

Right now we look for output from the test and if there is no output for TIMEOUT (=300 seconds default unless otherwise specified) then we fail the test as a timeout and continue on.  If we get 4 timeouts, then we terminate the entire job.

There will be tests which fail when we do this and we can use:
https://dxr.mozilla.org/mozilla-central/search?q=requestLongerTimeout&redirect=true&case=true&limit=51&offset=51

In fact we should probably audit some of the longer running tests if we can break them up, if they are valid, etc.
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1212051
You need to log in before you can comment on or make changes to this bug.