Selecting the top crashers reports for Thunderbird picks a Firefox version

RESOLVED FIXED

Status

Socorro
General
RESOLVED FIXED
3 years ago
10 months ago

People

(Reporter: mbrandt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [prod][regression][fromAutomation], URL)

(Reporter)

Description

3 years ago
Selecting the Top crash reports for Thunderbird returns a 404 error. Curiously this is only reproducible on production: https://crash-stats.mozilla.com/topcrasher/products/Thunderbird/versions/40.0b1

Stage redirects to: https://crash-stats.allizom.org/topcrasher/products/Thunderbird/versions/38.0.1

Steps to reproduce:
0. Goto https://crash-stats.mozilla.com
1. In the page header, filter Product by Thunderbird
2. In the header, filter report by 'Top Crashers'

Expected:
The Top Crashers report for Thunderbird and the appropriate version is displayed

Actual:
The Top Crashers report 404s
I think the 404 isn't the bug. The bug is that you can select a report without having selected a version. 
https://www.dropbox.com/s/ls87i9ozper189w/Screenshot%202015-09-24%2012.52.14.png?dl=0

There's no selected version :(

Do you know how this works Adrian?
Flags: needinfo?(adrian)
Summary: [prod] Selecting the top crashers reports for Thunderbird defaults to 40.0b1 returns a 404 → Selecting the top crashers reports for Thunderbird picks a Firefox version
(Reporter)

Comment 2

3 years ago
(In reply to Peter Bengtsson [:peterbe] from comment #1)
> I think the 404 isn't the bug. The bug is that you can select a report
> without having selected a version.

Good point, I'm not sure what the behavior was before, although it is curious that it's choosing a version that isn't available.
When no version is selected in the dropdown, TCBS is going to try and find a default version number. You can see that being behavior if you go to https://crash-stats.mozilla.com/topcrasher/products/Firefox - that redirects to the same page with the version set to whatever latest version we know. 

I believe the problem here is that 40.0b1 is somehow considered a valid version for Thunderbird when it isn't for TCBS. But I do not know why, though.
Flags: needinfo?(adrian)
(Reporter)

Comment 4

3 years ago
Kairo, are you able to shed knowledge on this?
Flags: needinfo?(kairo)

Comment 5

3 years ago
Sorry, I have no idea.
Flags: needinfo?(kairo)
I think this is fixed at this point. Please re-open if it's not.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.