[Marketplace]: localized legal docs not linked on Marketplace landing page or legal hub

VERIFIED FIXED

Status

Marketplace
Consumer Pages
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: CocoMo, Assigned: spasovski)

Tracking

Points:
---

Details

Hello,

Could someone look into this soon why these pages are not linked at the footer of the Marketplace landing page:

https://marketplace.firefox.com/?lang=xx.

1). Once on the page, for example "ro" or "ar", 
2). Find the Privacy Notice or ToS link on the footer, click on it.
3). Notice the doc itself is in English. I am not even sure the English version is the latest.

Same with the legal hub as well: https://www.mozilla.org/ro/about/legal/?lang=xx If the implementation of this belongs to the web dev team, I will file a separate bug.  

In addition, https://marketplace.firefox.com/developers/docs/policies/agreement/?lang=ro is still in English

We probably need to do an audit to make all our recently launched markets have all the required legal docs updated.

Thanks,
Peiying
ro was a new locale so it wouldn't have shown up until we merged the legal docs to the repository anyway.  I'm not sure why arabic isn't working though, so leaving the bug open for that.

I've merged the legal docs as of now so everything is up to date (including ro).
(Reporter)

Comment 2

2 years ago
Here is another one: https://marketplace.firefox.com/privacy-policy?lang=ro (change it to ar, sw, de, fr...) I haven't checked all of them, but it seems like none of them are linked correctly.

Updated

2 years ago
Priority: -- → P1
(Assignee)

Updated

2 years ago
Assignee: nobody → dspasovski

Updated

2 years ago
Duplicate of this bug: 1221805

Updated

2 years ago
Assignee: dspasovski → kngo

Updated

2 years ago
Assignee: kngo → dspasovski
You need to log in before you can comment on or make changes to this bug.