[Dev] Cannot add addons to a collection

VERIFIED FIXED in 44.1

Status

addons.mozilla.org Graveyard
Collections
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Victor Carciu, Assigned: andym)

Tracking

unspecified
44.1

Details

(URL)

(Reporter)

Description

2 years ago
Prerequsites:
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

Steps to reproduce:
1.Open MP-dev and try to create a new collection
2.Try to add a new addon , by entering the addon name in "Add-ons in your collection section"

Expected results:
A list of addons suggestions is displayed

Actual results:
Waiting spinner wheel is continuously displayed and addons list is never opened

Please see screencast for this bug : http://screencast.com/t/bVOQCW87
Console error : TypeError: e.curCSS is not a function

NOTE:
NOT reproducible on stage
Same issue encountered when trying to add addons to existent collections
(Reporter)

Updated

2 years ago
Assignee: nobody → me
(Assignee)

Updated

2 years ago
Assignee: me → amckay
Target Milestone: 44.2 → 44.1
(Assignee)

Comment 1

2 years ago
jquery-ui would need to be updated, or add in `jQuery.curCSS = jQuery.css;` at the top of jquery UI files. Doing the latter, I can get past this error, but then the autocompleter seems to not work.
(Assignee)

Comment 2

2 years ago
I'll also note that the "Add to collection" button on an add-on doesn't work, it should be capturing the submit event, but its not:

 $widget.delegate('#collections-new-cancel', 'click', loadList)
        .delegate('#add-to-collection form', 'submit', handleSubmit);

Which means that after hitting this dialog:

https://www.dropbox.com/s/8zvqz7sbrkdj863/Screenshot%202015-09-25%2018.02.02.png?dl=0

The page reloads and no collection is added.
(In reply to Andy McKay [:andym] from comment #2)
> I'll also note that the "Add to collection" button on an add-on doesn't
> work, it should be capturing the submit event, but its not:
> 
>  $widget.delegate('#collections-new-cancel', 'click', loadList)
>         .delegate('#add-to-collection form', 'submit', handleSubmit);
> 
> Which means that after hitting this dialog:
> 
> https://www.dropbox.com/s/8zvqz7sbrkdj863/Screenshot%202015-09-25%2018.02.02.
> png?dl=0
> 
> The page reloads and no collection is added.

This seems to be the same as this: bug 1208406 which has a PR here: https://github.com/mozilla/olympia/pull/788

Comment 5

2 years ago
Commits pushed to master at https://github.com/mozilla/olympia

https://github.com/mozilla/olympia/commit/ea70f06df60f6f4aa041931c207091d45fdc6241
add in jquery.menu and change data element lookup (bug 1208395)

https://github.com/mozilla/olympia/commit/f80f73c1fadbde0cd45ff3942566214a165b615c
Merge pull request #791 from andymckay/1208395

add in jquery.menu and change data element lookup (bug 1208395)
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Comment 6

2 years ago
There is an issue regarding the "waiting spinner wheel": even if the addon is added to the new collection, the spinner does not disappear. 
Please see the screencast: http://screencast.com/t/gKzokCGE8SOQ
Reproduced on AMO-stage and dev using FF41(Win 7)

Is this a regression from this fix, or another issue?
Thanks!
Flags: needinfo?(amckay)
(Assignee)

Comment 7

2 years ago
(In reply to ValentinaP from comment #6)
> There is an issue regarding the "waiting spinner wheel": even if the addon
> is added to the new collection, the spinner does not disappear. 
> Please see the screencast: http://screencast.com/t/gKzokCGE8SOQ
> Reproduced on AMO-stage and dev using FF41(Win 7)
> 
> Is this a regression from this fix, or another issue?
> Thanks!

If you are talking about bug 1211692, I think it's a different issue, its just really slow and sometimes timing out. Unless you see a JS error on the console, leave this one closed.
Flags: needinfo?(amckay)
(Reporter)

Comment 8

2 years ago
Verified as fixed
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.