Cannot complete payment by unexpected error (JWT is too large, doesn't fit in session)

RESOLVED WONTFIX

Status

Marketplace
Payments/Refunds
P3
critical
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: marsf, Assigned: kumar)

Tracking

Avenir
Points:
---

Details

(Reporter)

Description

2 years ago
After bug 1193918 has fixed, I cannot complete the payment yet by UNEXPECTED_ERROR.

https://marketplace.firefox.com/app/hyakunin-isshu

Reproduced on Firefox OS 2.2 and Firefox Desktop (any version).

minimum log:
[lib][wait] Starting global transaction timer. main.min.js:66:2270
[lib][wait] polling /mozpay/v1/api/pay/trans_start_url until status 0 main.min.js:66:2776
GET XHR https://marketplace.firefox.com/mozpay/v1/api/pay/trans_start_url [HTTP/1.1 400 BAD REQUEST 563ms]
[utils] could not find error_code in response:  main.min.js:62:30519
[lib][wait] Clearing global transaction timer. main.min.js:66:2182
[lib][wait] error reason UNEXPECTED_ERROR main.min.js:66:4951



I am understanding that here is not the place to say this, but I have to say:
Who is responsible to the Payment system's QA?
I am disappointed very much for annoying bug chains.
(Reporter)

Comment 1

2 years ago
Kumar, who can take this bug?
This is continuation of bug 1193918, which means we are stopped just after pin input.
Flags: needinfo?(kumar.mcmillan)
OS: Unspecified → All
Thanks for the ping. I can take a look after bug 1210889 (which is unrelated).

Comment 3

2 years ago
(In reply to Masahiko Imanaka [:marsf] from comment #0)
> I am understanding that here is not the place to say this, but I have to say:
> Who is responsible to the Payment system's QA?
> I am disappointed very much for annoying bug chains.


@marsf, sorry about all the issues you are seeing with your app. Please note that the issue is specific to your app and not widespread to all apps. We will get the issue resolved as soon as possible.

Updated

2 years ago
Severity: normal → critical
Priority: -- → P3
The problem: when purchasing this app, the session cookie gets to around 6612 bytes which exceeds Firefox's limit of 4096 bytes. This causes the session to be lost and that triggers the UNEXPECTED_ERROR. This is similar to bug 1193918 in that your app has a lot of localizations and thus has a large JWT (JSON Web Token) which makes the session very large. This is bad design on our part, sorry. I think I can fix it by not storing the whole JWT in the session. We might not need it all for the payment flow.
Assignee: nobody → kumar.mcmillan
Flags: needinfo?(kumar.mcmillan)
Summary: Cannot complete payment by unexpected error → Cannot complete payment by unexpected error (JWT is too large, doesn't fit in session)
(Reporter)

Comment 5

2 years ago
Thank you for investigation. I'll keep localizations of my app to fixing this bug.
(Reporter)

Comment 6

2 years ago
Any progress, or point to related code for reducing session data size?
(Reporter)

Comment 7

2 years ago
I removed many localizations for app descriptions, and payment process is working now.
However, this critical bug is NOT FIXED until comment 4 is addressed.
Please don't close this bug for it.

Comment 8

2 years ago
Based on the recently announced future plans for the Marketplace to remove payments, closing these bugs.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.