Closed Bug 1208526 Opened 6 years ago Closed 1 year ago

ARM64: Reenable jsapi-tests/testPreserveJitCode once Ion is enabled

Categories

(Core :: JavaScript Engine: JIT, defect, P5)

ARM64
Unspecified
defect

Tracking

()

RESOLVED DUPLICATE of bug 1426006

People

(Reporter: jolesen, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Whiteboard: [arm64:m3])

The test case in jsapi-tests/testPreserveJitCode only works when Ion is enabled, and the test was disabled for JS_CODEGEN_ARM64.

After Ion is enabled for ARM64, delete the special-case code in the test.
See Also: → 1208259
Priority: -- → P5
Hardware: Unspecified → ARM64
Whiteboard: [arm64:m2]
Assignee: stoklund → nobody

Sean says this bug is to re-enable a test that only works with Ion. Thus it doesn't block landing Ion; it depends on landing Ion before we can re-enable it.

Whiteboard: [arm64:m2] → [arm64:m3]

Bug 1523015 enabled Ion on ARM64 and bug 1426006 removed the #ifdef guard.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1426006
You need to log in before you can comment on or make changes to this bug.