Closed Bug 1208700 Opened 6 years ago Closed 6 years ago

Data Manager is broken to the point of unusability

Categories

(SeaMonkey :: Passwords & Permissions, defect)

SeaMonkey 2.39 Branch
x86_64
Linux
defect
Not set
major

Tracking

(seamonkey2.41 affected)

RESOLVED DUPLICATE of bug 1188348
Tracking Status
seamonkey2.41 --- affected

People

(Reporter: tonymec, Unassigned)

References

Details

(Keywords: useless-UI)

UA "Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0 SeaMonkey/2.41a1" ID:20150925112010 c-c:e595204ac23929b5b392fc21a3212dffef8a52e1 m-c:e5effeb8e57ceddf679f7784faab0c2cebb1e1e6

I'm not sure which component this bug report is for. Not something in "Core" since AFAIK Firefox hasn't got our Data Manager. Please move to a more suitable Component if you know one.

This is not the first build where I had this, but I've been a month or so with no Internet so I can't tell when it began.

Data Manager is badly broken. Most tabs are greyed-out. "* → Form Data" and "<specific host> → Cookies" are filled-in and seem to work. "* → Permissions" is not greyed-in but it is empty, and trying to define a new permission has no effect.

At first I thought this was bug 1045989 but I've been told there to open a new bug.
Keywords: useless-UI
The problem is just as bad in Safe Mode, which seems to rule out interference from some extension.
(In reply to Tony Mechelynck from comment #0)
> Data Manager is badly broken. Most tabs are greyed-out. "* → Form Data" and
> "<specific host> → Cookies" are filled-in and seem to work. "* →
> Permissions" is not greyed-in but it is empty, and trying to define a new
> permission has no effect.
Yeah, the permissions API got changed and Data Manager needs to be fixed.
Component: General → Passwords & Permissions
> Yeah, the permissions API got changed and Data Manager needs to be fixed.
Any hints on how to do this?
See Also: → 1121291
Regression from bug 1165263 which landed in Gecko 42.
Actually, that was the bug linked from the Mozilla blog, but I don't actually see the permission manager methods change there. Maybe the change was in one of the dependent bugs, such as bug 1170200.
Blocks: 1213089
i think this one is about the same problem as "Bug 1188348 - data manager: domains invisible for Permissions, Preferences, Passwords"
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1188348
No longer blocks: 1213089
Also due to comment 4 we should distinguish bugs what appeared with 2.38 from bugs what appeared with 2.39 (with Gecko 42)
Version: Trunk → SeaMonkey 2.39 Branch
You need to log in before you can comment on or make changes to this bug.