java plugin not working on Linux

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
2 years ago
a year ago

People

(Reporter: ilan, Unassigned)

Tracking

41 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [see comment #4])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux i686 (x86_64)) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11

Steps to reproduce:

my system is linux openSUSE 12.1 (Asparagus) (x86_64)
installed firefox from source
installed JRE from jre-8u60-linux-i586.rpm
created plugins directory under linux
symbolic link libnpjp2.so -> /usr/java/jre1.8.0_60/lib/i386/libnpjp2.so
verified java by http://java.com/en/download/installed8.jsp
tested java works on chrome. It does


Actual results:

no plugin found


Expected results:

disply succesful java plugin
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Updated

2 years ago
Component: Untriaged → Plug-ins
Product: Firefox → Core

Comment 1

2 years ago
Are you using the 32-bit or 64-bit version of Firefox? Firefox only loads plugins from the same architecture. Since you appear to be running a 64-bit version of Linux, what architecture is your Firefox?

What plugins directory are you using? Note that stock (mozilla.org) Firefox always uses /usr/lib/mozilla/plugins regardless of whether you're using the 32-bit or 64-bit version.  Some disto builds of Firefox change this behavior.
Flags: needinfo?(isbarak)
(Reporter)

Comment 2

2 years ago
my firefox is 32bit, as verified at  panopticlick.eff.org : Mozilla/5.0 (X11; Linux i686 on x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
following your comment I have created a directory /usr/lib/mozilla/plugins/ and linked the plugin there
ILANS:/usr/lib/mozilla/plugins # ls -l
total 0
lrwxrwxrwx 1 root root 41 Sep 28 19:37 libnpjp2.s0 -> usr/java/jre1.8.0_60/lib/i386/libnpjp2.s0
restarted firefox, tested at java.com, still no java
Flags: needinfo?(isbarak)

Comment 3

2 years ago
I don't think we're going to have time to investigate/prioritize this, with the impending removal of NPAPI support more generally. I'd take a patch if there's an obvious fix, so if you find the cause and want to write a patch, please feel free to reopen this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
FWIW, I'm running a more recent version (64-bit Leap 42.1) of the same openSUSE distribution, where NPAPI plugins are distributed in /usr/lib64/browser-plugins — and I'm running linux-x86_64 versions of Firefox and of SeaMonkey, not the versions distributed by openSUSE but trunk builds from Mozilla (for Firefox) or from A.Kalla who builds from Mozilla sources on his own computer when the nightlies at ftp.m.o are too much behind the times (for SeaMonkey). Both browsers behave identically concerning NPAPI plugins.

I have created a soft link from ~/.mozilla/plugins to /usr/lib64/browser-plugins (where openSUSE puts its 64-bit NPAPI plugins), and there I find the .so executables of most plugins, but for Java a further link chain:
/usr/lib64/browser-plugins/javaplugin.so -> /etc/alternatives/javaplugin
/etc/alternatives/javaplugin -> /usr/lib64/java-1_8_0-openjdk-plugin/lib/IcedTeaPlugin.so

This final link (at the end of the chain) is what I see in about:plugins under the title "IcedTea-Web Plugin (using IcedTea-Web 1.6.1 (suse-1.2-x86_64))" and with the description "The IcedTea-Web Plugin executes Java applets.". 

AFAICT, in current trunk the preference plugin.expose_full_path doesn't exist anymore and always behaves as if true.

The above-mentioned soft link (from ~/.mozilla/plugins to /usr/lib/browser-pluginis) works because I'm using 64-bit browsers with 64-bit plugins. As Benjamin mentioned in comment 1, mixing architectures doesn't work. The only file in /usr/lib/browser-plugins is named libnptcl3.1.so and has the same date but not the same size as a file of the same name in /usr/lib64/browser-plugins: presumably they are 32-bit and 64-bit respectively. For some reason however I don't see this particular plugin in about:plugins or in the Plugins tab of about:addons so I don't know what it is about. There is also no plugins/ subdirectory in /usr/lib/mozilla/ on this machine.
Whiteboard: [see comment #4]
All NPAPI plugins other than Flash are now totally disregarded on all platforms => WONTFIX.
Resolution: INCOMPLETE → WONTFIX
You need to log in before you can comment on or make changes to this bug.