Intermittent make[6]: *** [/home/worker/objdir-gecko/objdir/addon-sdk/source/test/addons/.mkdir.done] Error 1

RESOLVED DUPLICATE of bug 1207428

Status

Add-on SDK
General
RESOLVED DUPLICATE of bug 1207428
3 years ago
2 years ago

People

(Reporter: aryx, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

00:55:49     INFO -  mkdir -p '/home/worker/objdir-gecko/objdir/addon-sdk/source/test/addons/'
00:55:49     INFO -  mkdir: cannot create directory `/home/worker/objdir-gecko/objdir/addon-sdk/source/test/addons/': No such file or directory
00:55:49    ERROR -  make[6]: *** [/home/worker/objdir-gecko/objdir/addon-sdk/source/test/addons/.mkdir.done] Error 1
00:55:49     INFO -  make[6]: Leaving directory `/home/worker/objdir-gecko/objdir/addon-sdk'
00:55:49    ERROR -  make[5]: *** [addon-sdk/misc] Error 2
00:55:49     INFO -  make[5]: *** Waiting for unfinished jobs....

00:55:49     INFO -  make[5]: Leaving directory `/home/worker/objdir-gecko/objdir'
00:55:49    ERROR -  make[4]: *** [misc] Error 2
00:55:49     INFO -  make[4]: Leaving directory `/home/worker/objdir-gecko/objdir'
00:55:49    ERROR -  make[3]: *** [default] Error 2
00:55:49     INFO -  make[3]: Leaving directory `/home/worker/objdir-gecko/objdir'
00:55:49    ERROR -  make[2]: *** [realbuild] Error 2
00:55:49     INFO -  make[2]: Leaving directory `/home/worker/workspace/gecko'
00:55:49    ERROR -  make[1]: *** [build] Error 2
00:55:49     INFO -  make[1]: Leaving directory `/home/worker/workspace/gecko'
00:55:49     INFO -  make: *** [out/target/product/hammerhead/obj/DATA/gecko_intermediates/gecko] Error 2
00:55:50     INFO -  real	35m58.615s
00:55:50     INFO -  user	226m24.332s
00:55:50     INFO -  sys	31m42.518s
00:55:50     INFO -  
00:55:50     INFO -  > Build failed! <
00:55:50     INFO -  Build with |./build.sh -j1| for better messages
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
This is another of the fall out from the cache issues.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1207428
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 39

3 years ago
60 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 28
* b2g-inbound: 17
* fx-team: 9
* try: 3
* mozilla-central: 3

Platform breakdown:
* b2g-device-image: 59
* b2g-emu-ics: 1

For more details, see:
http://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1208729&startday=2015-09-28&endday=2015-10-04&tree=all

Comment 40

3 years ago
41 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 27
* b2g-inbound: 6
* try: 3
* mozilla-central: 3
* fx-team: 2

Platform breakdown:
* b2g-device-image: 39
* b2g-emu-x86-kk: 1
* b2g-emu-jb: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1208729&startday=2015-10-05&endday=2015-10-11&tree=all

Comment 41

3 years ago
25 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 10
* try: 7
* b2g-inbound: 6
* mozilla-central: 1
* fx-team: 1

Platform breakdown:
* b2g-device-image: 19
* mulet-linux64: 3
* android-4-3-armv7-api11: 2
* android-4-0-armv7-api11: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1208729&startday=2015-10-14&endday=2015-10-14&tree=all

Comment 42

3 years ago
60 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 21
* b2g-inbound: 15
* try: 10
* fx-team: 10
* mozilla-central: 4

Platform breakdown:
* b2g-device-image: 53
* mulet-linux64: 3
* android-4-3-armv7-api11: 2
* b2g-emu-ics: 1
* android-4-0-armv7-api11: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1208729&startday=2015-10-12&endday=2015-10-18&tree=all

Comment 43

3 years ago
39 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 20
* fx-team: 7
* b2g-inbound: 7
* try: 3
* mozilla-central: 2

Platform breakdown:
* b2g-device-image: 37
* b2g-emu-kk: 1
* b2g-emu-ics: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1208729&startday=2015-10-19&endday=2015-10-25&tree=all

Comment 44

3 years ago
56 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 28
* fx-team: 11
* b2g-inbound: 11
* try: 3
* mozilla-central: 3

Platform breakdown:
* b2g-device-image: 54
* linux64: 1
* b2g-emu-x86-kk: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1208729&startday=2015-10-26&endday=2015-11-01&tree=all

Comment 45

3 years ago
50 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 27
* b2g-inbound: 11
* fx-team: 6
* mozilla-b2g44_v2_5: 3
* mozilla-central: 2
* try: 1

Platform breakdown:
* b2g-device-image: 49
* b2g-emu-ics: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1208729&startday=2015-11-02&endday=2015-11-08&tree=all

Comment 46

3 years ago
43 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 16
* fx-team: 11
* b2g-inbound: 8
* try: 4
* mozilla-central: 3
* mozilla-b2g44_v2_5: 1

Platform breakdown:
* b2g-device-image: 40
* b2g-emu-l: 2
* b2g-emu-ics: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1208729&startday=2015-11-09&endday=2015-11-15&tree=all

Comment 47

2 years ago
17 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 11
* mozilla-inbound: 4
* fx-team: 2

Platform breakdown:
* b2g-device-image: 11
* b2g-emu-x86-kk: 3
* b2g-emu-kk: 1
* b2g-emu-jb: 1
* b2g-emu-ics: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1208729&startday=2015-11-16&endday=2015-11-22&tree=all

Comment 48

2 years ago
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 6

Platform breakdown:
* b2g-emu-l: 2
* b2g-device-image: 2
* b2g-emu-kk: 1
* b2g-emu-ics: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1208729&startday=2015-11-30&endday=2015-12-06&tree=all

Comment 49

2 years ago
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 5

Platform breakdown:
* b2g-device-image: 4
* b2g-emu-kk: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1208729&startday=2015-12-07&endday=2015-12-13&tree=all

Comment 50

2 years ago
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 6

Platform breakdown:
* b2g-device-image: 3
* b2g-emu-kk: 2
* b2g-emu-x86-kk: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1208729&startday=2015-12-14&endday=2015-12-20&tree=all

Comment 51

2 years ago
5 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 5

Platform breakdown:
* b2g-device-image: 3
* b2g-emu-ics: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1208729&startday=2015-12-21&endday=2015-12-27&tree=all

Comment 52

2 years ago
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 6

Platform breakdown:
* b2g-device-image: 3
* b2g-emu-x86-kk: 1
* b2g-emu-l: 1
* b2g-emu-jb: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1208729&startday=2016-01-11&endday=2016-01-17&tree=all

Comment 53

2 years ago
6 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* try: 6

Platform breakdown:
* b2g-device-image: 3
* b2g-emu-jb: 2
* b2g-emu-kk: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1208729&startday=2016-01-18&endday=2016-01-24&tree=all
(In reply to Nigel Babu [:nigelb] from comment #16)
> This is another of the fall out from the cache issues.
> 
> *** This bug has been marked as a duplicate of bug 1207428 ***

Is it? I just ran into this on a try build that is only building the browser. It's my own in-development job, and it was using --interactive, but at the beginning I just logged in and let the regular build stuff run. I came back to it to find that it errored out with this message.

https://tools.taskcluster.net/task-inspector/#ND1D9J2YSm6U4ngQmVNGCg/0

It seemed to me more like some weirdo race condition in the build system, though I don't understand how a mkdir -p could race unless some intermediate entry in the full path being created were a file instead of a directory or something.

Disturbing.
You need to log in before you can comment on or make changes to this bug.