crash in nsContentUtils::IsCallerChrome() when dragover the selected text on top of the searchbar

RESOLVED DUPLICATE of bug 1208517

Status

()

--
critical
RESOLVED DUPLICATE of bug 1208517
3 years ago
3 years ago

People

(Reporter: alice0775, Unassigned)

Tracking

({crash})

44 Branch
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupe me])

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-5d18eddc-aa93-44b7-8f12-08aee2150926.
=============================================================

Similar to Bug 1208517.
However, m-i build cset 66182160cc28 (incl patch of Bug 1208517) did not fix this crash.

Steps to Reproduce:
1. Select any text of the web page
2. Drag the selected text over SeacrhBar

Actual Results:
Nightly crashes immediately


Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8bdf0fb54af38f04133f875afe3fbe9e84576273&tochange=f23c63830ae5

Regressed by: Bug 1072150

Updated

3 years ago
See Also: → bug 1208769

Comment 1

3 years ago
same here, on linux amd64
(Reporter)

Comment 2

3 years ago
Fixed by backed out Bug 1072150.
No longer crash.

https://hg.mozilla.org/mozilla-central/rev/6256ec9113c115141aab089c45ee69438884b680
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0 ID:20150926160323
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

3 years ago
status-firefox43: --- → affected
status-firefox44: --- → fixed
(Reporter)

Updated

3 years ago
status-firefox43: affected → unaffected
Version: 43 Branch → 44 Branch

Comment 3

3 years ago
Wait so has this bugged been fixed? I'm still getting it on the latest nightly.

Comment 4

3 years ago
The Nightly which has the problematic patch backed out should be ready now.

Updated

3 years ago
Blocks: 1072150
Crash Signature: [@ nsContentUtils::IsCallerChrome()]
status-firefox43: unaffected → ---
status-firefox44: fixed → ---
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1208517

Updated

3 years ago
Duplicate of this bug: 1208767
You need to log in before you can comment on or make changes to this bug.