crash in nsContentUtils::SubjectPrincipal() (possibly related to LastPass)

RESOLVED DUPLICATE of bug 1208517

Status

()

Core
DOM: Core & HTML
--
critical
RESOLVED DUPLICATE of bug 1208517
2 years ago
2 years ago

People

(Reporter: gps, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
This bug was filed from the Socorro interface and is 
report bp-7602ff4a-49da-4681-86e7-b00ff2150926.
=============================================================

This is 100% reproducible for me by right clicking on some form fields on the 2015-09-26 Nightly on Windows 10. Not using e10s. It is possibly an interaction issue with LastPass, which provides extra items on the context menu when you right click. Currently using version 3.2.21 of LastPass, which was apparently also updated today. So LastPass could be the trigger here.

Comment 1

2 years ago
I've reproduced this 5 times on Thunderbird Daily from this morning. I do have the View About extension that adds items to the menus. Looks to be related to bug 1208758 ?
(Reporter)

Comment 2

2 years ago
And I got it on a comment box on GitHub as well. https://crash-stats.mozilla.com/report/index/33be5586-c7ae-4a63-9ae5-b8ff92150926. That's 4 crashes today.

Comment 3

2 years ago
Right click into the address bar with all add-ons & e10s disabled:
bp-ba19a3a6-f5a3-40fc-b66f-8db812150926
So add-ons should not be a reason for this crash.
(It looks like we have effectively broken nsContentUtils::IsCallerChrome() method atm.)

Updated

2 years ago
See Also: → bug 1208758

Comment 6

2 years ago
happens also on linux/amd64
Looking at the stack in comment 0, this is a dupe of bug 1208517.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1208517
Crash Signature: [@ nsContentUtils::SubjectPrincipal()]
See Also: bug 1208758
You need to log in before you can comment on or make changes to this bug.