Show the page URL in the Site Identity Button's drag-image/tooltip.

RESOLVED FIXED in Firefox 68

Status

()

enhancement
P5
normal
RESOLVED FIXED
4 years ago
25 days ago

People

(Reporter: johan.charlez, Assigned: aqadri, Mentored)

Tracking

(Blocks 1 bug)

39 Branch
Firefox 68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Reporter

Description

4 years ago
STR:
1. Load a website.
2. Drag the Site Identity Button.

Actual result:
The Site Identity Button's icon (padlock/globe/warning triangle) is set as the drag-image/tooltip.

Expected result/suggestions:
  a) Show the full URL instead.
  b) Show the full URL in addition to the Site Identity Button icon (padlock/globe/warning triangle).
  c) Show the full URL in and the page's favicon instead.
Reporter

Updated

4 years ago
Duplicate of this bug: 1208857
Component: Location Bar → Site Identity and Permission Panels
Priority: -- → P5

We are currently setting the drag image here: https://searchfox.org/mozilla-central/rev/a7315d78417179b151fef6108f2bce14786ba64d/browser/base/content/browser-siteIdentity.js#927-932

What we might need to do is to create a Canvas element and draw the URL into the canvas, then set that canvas as the drag image.

Mentor: jhofmann
Assignee

Updated

3 months ago
Assignee: nobody → asra.qadri
Attachment #9053913 - Attachment is obsolete: true
Assignee

Updated

2 months ago
Keywords: checkin-needed

Comment 5

2 months ago

Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/efbc44239b5c
Show the page URL in the Site Identity Button's drag-image/tooltip. r=johannh

Keywords: checkin-needed

Comment 6

2 months ago
bugherder
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Type: defect → enhancement

Comment 7

25 days ago

I have reproduced this bug with Firefox nightly 44.0a1 (2015-09-27) on ManjaroLinux, 64 Bit.

The Bug's fix is now verified on latest beta 68.0b4 (2019-05-23)

Build ID: 20190523115432

User Agent : Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

QA Whiteboard: [bugday-20190521]
You need to log in before you can comment on or make changes to this bug.