Closed Bug 1208901 Opened 4 years ago Closed 4 years ago

Fix a typo in nsStyleClipPath::nsStyleClipPath

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla44
Tracking Status
firefox44 --- fixed

People

(Reporter: ehsan, Assigned: ehsan)

References

Details

Attachments

(1 file)

Found by Viva64.  Seems to have been a copy-paste error.
Duplicate of this bug: 1208861
FWIW, this code isn't tested or run without the layout.css.clip-path-shapes.enabled pref set, and in any case since we don't have an actual implementation of the feature yet (just the CSS parsing) just having the values listed in property_database.js isn't sufficient to check that we store the values in the nsStyleClipPath correctly.

I hear someone is (planning on?) working on CSS Masking (which I assume would encompass implementing the new clip-path values too) so hopefully we'll get test coverage from that soon.
Attachment #8666518 - Flags: review?(cam) → review+
https://hg.mozilla.org/mozilla-central/rev/94063ba57686
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Blocks: 710966
Assignee: nobody → ehsan
You need to log in before you can comment on or make changes to this bug.