Unexpected error during validation

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Add-on Validation
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: kreon, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8666607 [details]
godville-ui-plus-firefox-latest.xpi

I'm trying to validate an existing unlisted add-on and getting an "unexpected error". It should be noted that this error occures either when submitting a new version of already existing add-on or even when trying to re-validate any old (already signed) version of this add-on.

For example, if I try to revalidate the oldest version I have in "Older versions" list of "Status & Versions" page for this add-on (it was successfully validated on 2015/06/17) by pressing a "Not validated. Validate now" button, I will get the same "unexpected error" (https://addons.mozilla.org/en-US/developers/addon/erinome-godville-ui/file/323402/validation).

The previous time I had successfully validated this add-on was on 2015/09/14. And since approx. 2015/09/25 I am unable to upload a new version as its validation every time ends with the "unextected error". So the the problem with the validator was introduced somewhere in between of 15 and 25th of September I suppose.

The validator URL: https://addons.mozilla.org/en-US/developers/addon/erinome-godville-ui/versions#version-upload
The approximate time I have submitted the add-on the last time: 2015/09/28 11:20 (GMT+3).

I'm attaching the same version as the latest already validated one. So the validator should probably produce a warning regarding "this addon already signed", but instead it just fails with the same "unexpected error" like that which happens on the new version validation.
Thanks for reporting. I've tried validating this add-on on both our dev server (https://addons-dev.allizom.org) and stage server (https://addons.allizom.org), and they both worked correctly (and indeed, it fails on https://addons.mozilla.org).

So I believe this issue is fixed, and the fix should go to production on thursday. I'm going to close this bug now, but please if you see this still happening after thursday, reopen it so we give it a closer look.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

3 years ago
Well, I believe thursday is over in all possible timezones in the world now and I'm still unable to validate any version of this add-on because of "an unexpected error" from the validator.

Looking at this situation, I'd suggest to add at least an option which would allow add-on developers to send their add-ons to manual review when auto-validation fails. Because otherwise there's just no single way to get the add-on validated when the validator throws unexpected errors at you.

PS: That probably won't help much though _currently_, as my other unlisted addon sits in manual review queue for the last 3 days now, and its position isn't even close to the middle of the queue... But still, sending add-ons to manual review when validator is broken might provide some hope that you eventually will get your add-on signed, as now it's just like "Hi, validator isn't working with your add-on, thats all we can tell you, next please!".
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Thursday's push was postponed until next week.
(Reporter)

Comment 4

3 years ago
Great. Then is it known when exactly that fix will be applied? Could I get a notification or something when that'll happen, or should I continue rechecking every day if "unexpected error" is gone? Or maybe are there any other options how to get this thing signed until validator finally gets fixed?

Comment 5

2 years ago
Assuming this is now resolved since the push happened a while ago. Please re-open if its still a problem. I just tried the attached add-on and it seemed to be ok.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.