Regression: On tab selection yields a grey flicker

RESOLVED FIXED

Status

()

Firefox for iOS
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: aaronmt, Assigned: sleroux)

Tracking

({regression, reproducible})

unspecified
Other
iOS
regression, reproducible

Firefox Tracking Flags

(fxios1.1+)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8666709 [details]
Screen Shot 2015-09-28 at 10.33.29 AM.png

On master (d95aee43a2247815a89b300ae7287048403ce80e), on tab selection yields a grey flicker for a second, see screenshot
tracking-fxios: ? → 1.1+
Assignee: nobody → etoop
Status: NEW → ASSIGNED
:aaronmt I cannot replicate this on current master. Is this still a problem?
Flags: needinfo?(aaron.train)
(Reporter)

Comment 2

2 years ago
Re-open if I see this again
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(aaron.train)
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

2 years ago
This is still reproducible albeit not 100% of the time. 

I was in settings, I clicked done, I tapped on the first about:home tab I had open.

Results: see screenshot
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 4

2 years ago
Might be related to private tabs since we hide the web content and it appears gray so that might be it.
Assignee: etoop → sleroux
Status: REOPENED → ASSIGNED
(Assignee)

Comment 5

2 years ago
Created attachment 8673258 [details] [review]
https://github.com/mozilla/firefox-ios/pull/1153

I wasn't able to reproduce this at all but I'm pretty sure I spotted the problem. :AaronMT, did you get a STR for this?
Flags: needinfo?(aaron.train)
Attachment #8673258 - Flags: review?(etoop)
(Reporter)

Comment 6

2 years ago
No specific steps
Flags: needinfo?(aaron.train)
Attachment #8673258 - Flags: review?(etoop) → review+
(Assignee)

Comment 7

2 years ago
Merged
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.