Clear Private Data - issue a warning prompt

VERIFIED FIXED

Status

()

VERIFIED FIXED
3 years ago
a year ago

People

(Reporter: aaronmt, Assigned: fluffyemily)

Tracking

unspecified
All
iOS

Firefox Tracking Flags

(fxios3.0+)

Details

(Whiteboard: [needs strings])

Attachments

(1 attachment)

48 bytes, text/x-github-pull-request
sleroux
: review+
tecgirl
: ui-review+
Details | Review | Splinter Review
(Reporter)

Description

3 years ago
Whilst a manually selected user action, clearing private data can be destructive. Currently Safari and Chrome issue a warning prompt:

Chrome - "Are you sure you want to clear all browsing data". They also offer a dynamic prompt per selection

Safari - "Clearing will remove history, cookies, and other browsing data. <Clear History and Data> <Cancel>.

We should issue a prompt.
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1209098
This ticket was created in response to Bug 1202810.

While there is a prompt, it's not very informative. Letting the user know exactly what will be cleared, or providing options that can be selected (with some auto-selected), would be ideal. Bug 1191450 may possibly provide this.
Given the way sync works and the fact that this could also delete data on other devices, I think this is a good idea. We just need to nail down the copy, but something like this could work (if its accurate)?

"This will delete data across any synced device and cannot be undone."

> Cancel
> Clear Data
Flags: needinfo?(rnewman)
tracking-fxios: ? → 2.0+
Flags: needinfo?(rnewman)
Flags: needinfo?(rnewman)
What gets wiped on other devices depends on what you've opted into or out of syncing. So yes, we need to offer caution but also be precise.

If Sync is set up (profile.hasAccount(), not profile.hasSyncAbleAccount()), then:

  If any of the selected items are things that we are able to sync (that is, we don't care if you're only clearing cookies), then:

    This action could delete data from your synced devices and cannot be undone.


I wouldn't say no to a Learn More link to explain how to figure out what to do.

Otherwise:

    This action cannot be undone.


If we're able to dig into the account object to figure out what the user has opted in to syncing (a fast path to get a Scratchpad's meta/global) then we can do a couple of smarter things:

    This action cannot be undone.                 (Not syncing any things we're deleting)
    This action will delete data from your synced devices.   (More definite than 'could')

or specific types

    This action will delete history and passwords from your synced devices.

or even

    This action will delete 1,234 history items from your synced devices.
Flags: needinfo?(rnewman)
Whiteboard: [needs strings]
(Reporter)

Comment 5

3 years ago
Some other bug implemented a yield on clear private data for history only when a connected account is detected
Flags: needinfo?(sarentz)
tracking-fxios: 2.0+ → 3.0+
(Assignee)

Updated

3 years ago
Assignee: nobody → etoop
Status: NEW → ASSIGNED
(Assignee)

Comment 6

3 years ago
So, we seem to have a few scenarios that may require notification to the user here.

Here are some suggestions for those scenarios. I'd be grateful for some guidance here.

1. We are clearing private data options that include History with a Firefox account. We have this currently.
      - title: Remove history from your Firefox Account?
      - message: History will be removed from all your connected devices. This cannot be undone.
2. We are clearing all private data options without a FxA
      - title: Clear Everything
      - message: Are you sure you want to clear all of your data? This will also close all open tabs and cannot be undone
3. We are clearing selected (but not all) private data that does not include history (regardless of FxA)
      - title: Clear Private Data
      - message: Are you sure you want to clear your selected private data? This cannot be undone.

or, do we need to do the general warning for every Private Data clear and an extra one if you're clearing history with an FxA?
Flags: needinfo?(randersen)
Flags: needinfo?(dhenein)
(Assignee)

Updated

3 years ago
Status: ASSIGNED → NEW
> or, do we need to do the general warning for every Private Data clear and an 
> extra one if you're clearing history with an FxA?

A general warning should suffice, with an additional mention of history if you're signed in.

This action will clear all of your private data. It cannot be undone.
[CANCEL]     [OK}

This action will clear all of your private data, including history from your synced devices.
[CANCEL]     [OK}
Flags: needinfo?(randersen)
Flags: needinfo?(dhenein)
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 8

3 years ago
Created attachment 8721947 [details] [review]
Pull request
Attachment #8721947 - Flags: ui-review?(randersen)
Attachment #8721947 - Flags: review?(sleroux)
(Assignee)

Updated

3 years ago
Blocks: 1250103
(Assignee)

Comment 9

3 years ago
Created linked bug for generating L10n snapshot tests for this. https://bugzilla.mozilla.org/show_bug.cgi?id=1250103
Comment on attachment 8721947 [details] [review]
Pull request

Looks good just some nits!
Attachment #8721947 - Flags: review?(sleroux) → review+
Comment on attachment 8721947 [details] [review]
Pull request

Emily, I'm not seeing updating strings…

What I'm seeing

SO:
Clear Private Data
This action will clear all of your private
data. It cannot be undone.

SI:
Remove history from your Firefox Account?
This action will clear all of you private 
data, including history from all of your
synced devices. It cannot be undone.
(Assignee)

Comment 12

3 years ago
Are they not the updated strings? Originally the no account case didn't exist and the text is as you specified, but I added the 'Clear Private Data' title.

The with account case is present too. I changed the main body text as requested (but added the ' This cannot be undone' as I felt it was important) but haven't updated the title text from what it was before.

If the title text should be different, please let me know what the title text should be. Or should I remove the title text completely?

I've updated the bug again removing the titles and cleaning the wording.
Flags: needinfo?(randersen)
Emily, I now see the updated strings. One nit; change the weight to normal. It seems to be using the bold title weight.
Flags: needinfo?(randersen)
(Assignee)

Comment 14

3 years ago
:tecgirl - amended the font weight.
Attachment #8721947 - Flags: ui-review?(randersen) → ui-review+
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Flags: needinfo?(sarentz)

Comment 15

a year ago
Verified as fixed on iPhone 6, iOS 10.2.1, Firefox version 8.0(1), buddybuil #2356
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.