Firefox Preferences rendered illegible with a white-on-black accessibility style sheet.

RESOLVED DUPLICATE of bug 1207084

Status

()

RESOLVED DUPLICATE of bug 1207084
3 years ago
3 years ago

People

(Reporter: tepesonen, Unassigned)

Tracking

({access, regression})

41 Branch
access, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150918100312

Steps to reproduce:

Go to Preferences -> Content -> Colours; set a white text on black background theme. Choose that the style is enforced always and no system colours are to be used.



Actual results:

Web pages are now correctly rendered white-on-black, overriding their stylesheets. The Preferences display, however, is drawn with white text but NOT with a black background. Instead, the background seems to be hard-coded to white. This makes the text and various UI elements, such as combo boxes and buttons, impossible to read, as they are of the same colour as the background. In corollary, the preferences cannot be perused or altered.

This change has occurred with the reported Firefox version. Previously, the Preferences view adhered to the enforced colour theme.


Expected results:

The Preferences display should conform to the set colours to maintain legibility. This has been the case in earlier Firefox versions.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Untriaged → CSS Parsing and Computation
Keywords: access, regression
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1207084
You need to log in before you can comment on or make changes to this bug.