Closed Bug 1209304 Opened 4 years ago Closed 4 years ago

Week view. Wrong date is displayed while a user adds a new event

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED DUPLICATE of bug 1209275
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: MaxIvanov, Assigned: gaye)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark])

Description:
When a user adds a new event in a Week mode it will be displayed incorrectly. 

Repro Steps:
1) Update a Aries to 20150928133112
2) Open the Calendar app
3) Tap on the Week button
4) Create a new event at any date
5) Start creating a second event at a different date
6) Observe a date of the new event

Actual:
The event start date will be displayed incorrectly

Expected:
The event start date according to the selected day by user

Environmental Variables:
Device: Aries Master
Build ID: 20150928133112
Gaia: 01ffe82cf088ca8fda9fe6783dc5cad2c3dde01c
Gecko: 031db40e2b558c7e4dd0b4c565db4a992c1627c8
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: (5/5)
See attached: (video clip, logcat)
https://youtu.be/84VFHMK-Gxs
QA Whiteboard: [QAnalyst-Triage?]
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
This issue DOES occur on Aries 2.5 and Flame 2.5 as well as on Flame 2.2 
Result: The event start date will be displayed incorrectly

Device: Aries Master
Build ID: 20150925134904
Gaia: 5a0a1bb1a863b07528ebc1a04652ed656d8333b3
Gecko: 543e1b3a25887258a70d1f2dab3cb287d0d500e4
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
--------------------------------------------------------------------

Device: Flame Master
Build ID: 20150925030204
Gaia: f1cb3089ee2a77dd779408ca86dbb5e4ed5af0b3
Gecko: e5effeb8e57ceddf679f7784faab0c2cebb1e1e6
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (Master)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
--------------------------------------------------------------------

Device: Flame 2.2
Build ID: 20150923003003
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: 65ddad73ad6b
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Flags: needinfo?(ktucker)
Correction: This issue DOES NOT occurs on Flame 2.2.
[Blocking Requested - why for this release]:

Major regression in Calendar.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: jthomas
blocking-b2g: 2.5? → 2.5+
Priority: -- → P2
Assignee: nobody → gaye
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1209275
Resolution: DUPLICATE → FIXED
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1209275
You need to log in before you can comment on or make changes to this bug.