Last Comment Bug 1209400 - CSS Paddings collapse in certain circumstances
: CSS Paddings collapse in certain circumstances
Status: RESOLVED DUPLICATE of bug 748518
[parity-chrome]
: testcase
Product: Core
Classification: Components
Component: Layout: Block and Inline (show other bugs)
: 41 Branch
: All All
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
http://jsfiddle.net/8nyh510w/3/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-28 23:23 PDT by joshwise1994
Modified: 2015-09-29 00:28 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image joshwise1994 2015-09-28 23:23:39 PDT
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.99 Safari/537.36

Steps to reproduce:

Create a parent element with "position: absolute", "top: 0", "left: 0", "right: 0", "bottom: 0", "overflow-y: auto", and "padding: 60px".

Then, give it a child element with "padding-bottom: 60px", and enough text content to overflow the parent and cause a scrolling behavior.

As seen here: http://jsfiddle.net/8nyh510w/3/


Actual results:

The bottom paddings of the parent and child collapse and overlap each other. This is NOT the behavior in Chrome or IE11.


Expected results:

The child's bottom padding should sit underneath the text content, inside the parent's content box, resulting in more scrollable area. The child's bottom padding should NOT collapse into the parent's bottom padding.
Comment 1 User image Gingerbread Man 2015-09-29 00:12:59 PDT
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:44.0) Gecko/20100101 Firefox/44.0
20150928030206

I get the same result in IE 11.
Comment 2 User image David Baron :dbaron: ⌚️UTC-8 2015-09-29 00:28:26 PDT

*** This bug has been marked as a duplicate of bug 748518 ***

Note You need to log in before you can comment on or make changes to this bug.