Building Firefox 42 beta: 'class gfxXlibSurface' has no member named 'GetGLXPixmap'

RESOLVED DUPLICATE of bug 1202175

Status

()

RESOLVED DUPLICATE of bug 1202175
3 years ago
3 years ago

People

(Reporter: ungift-ed, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150914133724

Steps to reproduce:

When building Firefox 42 I have issue:
firefox-42.0b2/gfx/layers/ipc/ShadowLayerUtilsX11.cpp:79:25: error: 'class gfxXlibSurface' has no member named 'GetGLXPixmap'

It seems you miss #if defined(GL_PROVIDER_GLX)
in: gfx/layers/ipc/ShadowLayerUtilsX11.cpp
and may be in: gfx/gl/SharedSurfaceGLX.cpp

Please look
(Reporter)

Comment 1

3 years ago
In my enviromnent I can build FF42 with this patch

diff -Naur firefox-42.0b2/gfx/layers/ipc/ShadowLayerUtilsX11.cpp firefox-42.0b2-2/gfx/layers/ipc/ShadowLayerUtilsX11.cpp
--- firefox-42.0b2/gfx/layers/ipc/ShadowLayerUtilsX11.cpp	2015-09-28 20:25:57.000000000 +0300
+++ firefox-42.0b2-2/gfx/layers/ipc/ShadowLayerUtilsX11.cpp	2015-09-29 12:15:47.682424210 +0300
@@ -75,9 +75,11 @@
     mFormat = cairo_xlib_surface_get_visual(aSurf->CairoSurface())->visualid;
   }
 
+#ifdef GL_PROVIDER_GLX
   if (aForwardGLX) {
     mGLXPixmap = aSurf->GetGLXPixmap();
   }
+#endif
 }
 
 SurfaceDescriptorX11::SurfaceDescriptorX11(Drawable aDrawable, XID aFormatID,
(Reporter)

Comment 2

3 years ago
Duplicate for bug 1202175
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1202175
You need to log in before you can comment on or make changes to this bug.