Closed Bug 1209466 Opened 7 years ago Closed 7 years ago

Subpixel smoothing is removed if mix-blend-mode is used

Categories

(Core :: Graphics, defect)

41 Branch
Unspecified
Windows
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ryan, Unassigned)

Details

(Whiteboard: [gfx-noted])

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150917150946

Steps to reproduce:

When setting mix-blend-mode on any element, subpixel smoothing for transforms is disabled.  This becomes apparent when animating a transform over a long period of time.

Reproduced on Win 10 & 7, no issue on OSX Yosemite.

Example: http://codepen.io/anon/pen/dYNyYY (click Blend Mode Off to toggle mix-blend-mode)


Actual results:

When mix-blend-mode is active the animated elements become jerky, snapping to whole pixels.


Expected results:

The elements should animate in the same way (smoothly) regardless of the blend mode of other elements.
Ryan, does this issue still reproduce?
Flags: needinfo?(ryan)
OS: Unspecified → Windows
Whiteboard: [gfx-noted]
(In reply to Anthony Hughes (:ashughes) [GFX][QA][Mentor] from comment #1)
> Ryan, does this issue still reproduce?

No, the issue has been resolved now.
Thanks for writing back, Ryan. I'm closing this bug since you can't reproduce it anymore. Please reopen this bug report if the issue returns.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Flags: needinfo?(ryan)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.