Closed Bug 1209527 Opened 7 years ago Closed 7 years ago

More information button is not visible while step 3 of the Control Center UITour is displayed

Categories

(Firefox :: Tours, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox44 --- affected

People

(Reporter: adalucinet, Unassigned)

References

Details

Reproducible with 42.0b2, latest 43.0a2 and 44.0a1 (from 2015-09-28)
Affected platforms: Windows 7 x64, Windows 8 x86 and Mac OS X 10.10.4

Steps to reproduce:
1. Launch Firefox and open a Private Browsing window.
2. Click on "See how this works" button. 
3. Click next in the UITour panels until step 3.
4. Expand/Collapse the Control Center.

Expected results: More information button is visible.

Actual result: More information button is not visible.

Additional notes:
1. Screen recording → https://goo.gl/aevNT4
2. On Ubuntu 14.04 x64, step 3 of the Control Center UITour remains in the background if the subpanel is visible → https://goo.gl/VYI8Hy
Whiteboard: [fxprivacy][triage]
The Tour callout panel is obscuring the "more info" button. In this case, the objective of the tour is to get users to pay attention to the TP UI. In this case, on step 3, they've completed the tour. If they close the callout or click "got it", normal browser function is restored.

This is working as intended.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
Whiteboard: [fxprivacy][triage]
(In reply to Javaun Moradi [:javaun] from comment #1)
> The Tour callout panel is obscuring the "more info" button. In this case,
> the objective of the tour is to get users to pay attention to the TP UI. In
> this case, on step 3, they've completed the tour. If they close the callout
> or click "got it", normal browser function is restored.
> 
> This is working as intended.

Thanks for the detailed information! Although, I have a feeling you didn't have the chance to look over the Ubuntu behavior:
> 2. On Ubuntu 14.04 x64, step 3 of the Control Center UITour remains in the background if the subpanel is visible → https://goo.gl/VYI8Hy

Shall I log a different bug and leave this one as wontfix?
Flags: needinfo?(jmoradi)
Hi Alexandra, I'm sorry I'm just clearing this. this one is already live, but I think it's a WONTFIX too. It is an issues as you note on Ubuntu, but our limitation with this callout panel is that we're limited in Toolkit. It's not ideal, but users can still close the panel. Practically speaking, we have no short-term way to fix it.
Flags: needinfo?(jmoradi)
You need to log in before you can comment on or make changes to this bug.