Closed Bug 1209587 Opened 4 years ago Closed 4 years ago

crash in mozilla::OriginAttributes::CreateSuffix(nsACString_internal&), Tab crashes if adblock plus installed

Categories

(Core :: DOM: Content Processes, defect, critical)

44 Branch
Unspecified
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1167100
Tracking Status
e10s ? ---
firefox44 --- affected

People

(Reporter: alice0775, Unassigned)

References

Details

(Keywords: crash, regression, reproducible)

Crash Data

Attachments

(1 file)

Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/acdb22976ff86539dc10413c5f366e1fb429a680
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0 ID:20150929030225


Steps To Reproduce:
1. Install adblock plus https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/versions/?page=1#version-2.6.11.3985-beta
2. Restart

Actual Results:
Tab crashes : bp-b570eced-1e96-4390-989b-ad3f32150929
Flags: needinfo?(allstars.chh)
Crash Signature: [@ mozilla::OriginAttributes::CreateSuffix(nsACString_internal&)] → [@ mozilla::OriginAttributes::CreateSuffix(nsACString_internal&)] [@ mozilla::OriginAttributes::CreateSuffix(nsACString_internal&) const]
My STR:

1. Enable e10s.
2. Enable Adblock Plus, uBlock, or Lightbeam. ABP is not required. Enabling any of these individual is adequate!
3. Open two links into background tabs, e.g. open https://news.ycombinator.com/ and then middle-click on two story links.

RESULT:

Crash when the second tab starts to load in the background.
Crashes on Ubuntu14.04
bp-30c84952-34c6-4a2b-96fa-cc76c2150929
This isn't the right fix, but it's probably better than backing out Yoshi's patch,
which is only incidentally affected by this issue.
Attachment #8667382 - Flags: review+
After discussing on IRC, we decided to back out bug 1167100 and respin nightlies as the quickest fix for this.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(allstars.chh)
Resolution: --- → DUPLICATE
Duplicate of bug: 1167100
Duplicate of this bug: 1209597
You need to log in before you can comment on or make changes to this bug.