Share your screen dropdown misplaced when window is large

RESOLVED FIXED in Firefox 43

Status

P2
normal
Rank:
29
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: ianbicking, Assigned: standard8)

Tracking

({regression})

unspecified
mozilla44
regression
Points:
---

Firefox Tracking Flags

(firefox42 unaffected, firefox43+ fixed, firefox44+ fixed)

Details

(Whiteboard: [visual refresh defect])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8667347 [details]
Screen Shot

See attached screenshot (made when Hello was maximized)

Firefox 44.0a1 (2015-09-28)

Comment 1

3 years ago
while we're planning to remove the button - it's there in 43.  believe there's already a bug on this as well.  will do if quick
Assignee: nobody → standard8
Rank: 29
Priority: -- → P2
Whiteboard: [visual refresh defect]
Created attachment 8668614 [details] [diff] [review]
Fix Loop's screenshare dropdown being misplaced on large window sizes.

Looks like we just need to swap to an anchor, and drop the styles that are getting in the way.
Attachment #8668614 - Flags: review?(mdeboer)
Comment on attachment 8668614 [details] [diff] [review]
Fix Loop's screenshare dropdown being misplaced on large window sizes.

Review of attachment 8668614 [details] [diff] [review]:
-----------------------------------------------------------------

Neat!
Attachment #8668614 - Flags: review?(mdeboer) → review+
https://hg.mozilla.org/mozilla-central/rev/0ee75d7cc16b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox44: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
Comment on attachment 8668614 [details] [diff] [review]
Fix Loop's screenshare dropdown being misplaced on large window sizes.

Approval Request Comment
[Feature/regressing bug #]: Visual refresh toolbar work. Probably bug 1184559
[User impact if declined]: If using the popped-out view of the conversation window, the dropdown menu for the screen share selection appears in the wrong place.
[Describe test coverage new/current, TreeHerder]: Code covered by unit tests.
[Risks and why]: Mainly css, the code change supports css, so low risk, only affects Hello
[String/UUID change made/needed]: None
Attachment #8668614 - Flags: approval-mozilla-aurora?
Tracking since this is a recent regression.
status-firefox42: --- → unaffected
status-firefox43: --- → affected
tracking-firefox43: --- → +
tracking-firefox44: --- → +
Keywords: regression
Comment on attachment 8668614 [details] [diff] [review]
Fix Loop's screenshare dropdown being misplaced on large window sizes.

Approved for aurora uplift; fix for recent regression
Attachment #8668614 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

3 years ago
Iteration: --- → 44.1 - Oct 5
You need to log in before you can comment on or make changes to this bug.