Closed Bug 1209600 Opened 9 years ago Closed 9 years ago

Merge button is being cutoff on the duplicates found screen

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5?, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.5?
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: KTucker, Assigned: apastor)

References

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(4 files)

The "Merge" button is being cutoff on the "Duplicates found" screen in contacts. This occurs with or without SHB enabled.

Repro Steps:
1) Update a Aries to 20150929110451
2) Create 2 contacts on the phone with duplicate information and observe the "Duplicates found" screen.

Actual:
The "Merge" button on the "Duplicates found" screen is being cutoff.

Expected:
The "Merge" button is full visible.

Environmental Variables:
Device: Aries 2.5
Build ID: 20150929110451
Gaia: f345f6a015709beeb2ca3955cab077fcaa959d3b
Gecko: acdb22976ff86539dc10413c5f366e1fb429a680
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 5/5 100%
See attached: screenshot, logcat
The issue also occurs on Flame 2.5 

The "Merge" button is cutoff. 

Device: Flame 2.5 (Full Flash)(KK)(319mb)
BuildID: 20150929030205
Gaia: f345f6a015709beeb2ca3955cab077fcaa959d3b
Gecko: acdb22976ff86539dc10413c5f366e1fb429a680
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

------------------------------

This issue does not occur on Flame 2.2

The "Merge" button is fully visible.

Device: Flame 2.2 (Full Flash)(KK)(319mb)
BuildID: 20150929032504
Gaia: 5dd95cfb9f1d6501ce0e34414596ef3dd9c2f583
Gecko: 65ddad73ad6b
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Whiteboard: [2.5-Daily-Testing][Spark]
Attached image MergeButton.png
[Blocking Requested - why for this release]:
Major regression in contacts.  Likely came back with the revert from NGA.
blocking-b2g: --- → 2.5?
Flags: needinfo?(jmercado)
QA Contact: jthomas
B2g Inbound Regression Window

Last Working
Environmental Variables:
Device: Flame 2.5
BuildID: 20150928043836
Gaia: 64cbcb532b538b36e92d99f66833a208e4a62e3e
Gecko: f69af71d34e23fde94fa595b0c393c6443ceff03
Version: 44.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken
Environmental Variables:
Device: Flame 2.5
BuildID: 20150928052158
Gaia: c1cccd5e74373c9f93f9505386a70daf3f566ae0
Gecko: 2bd0998e7c7185d70bbc87c7fe1067889b3480eb
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Last Working gaia / First Broken gecko - This issue does NOT occur with broken gecko.
Gaia: 64cbcb532b538b36e92d99f66833a208e4a62e3e
Gecko: 2bd0998e7c7185d70bbc87c7fe1067889b3480eb

Last Working gecko / First Broken gaia - This issue DOES occur with broken gaia.
Gecko: f69af71d34e23fde94fa595b0c393c6443ceff03
Gaia: c1cccd5e74373c9f93f9505386a70daf3f566ae0

B2G Inbound Pushlog: 
https://github.com/mozilla-b2g/gaia/compare/64cbcb532b538b36e92d99f66833a208e4a62e3e...c1cccd5e74373c9f93f9505386a70daf3f566ae0

This issue is caused by Bug 1168962
Blocks: 1168962
Flags: needinfo?(jmercado)
Alberto can you please take a look at this issue?  It seems to have been caused by the changes for bug 1168962.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(apastor)
Assignee: nobody → apastor
Flags: needinfo?(apastor)
Attachment #8667833 - Flags: review?(etienne)
Comment on attachment 8667833 [details] [review]
[gaia] albertopq:1209600-merge-button > mozilla-b2g:master

Nice testing, thanks!
Attachment #8667833 - Flags: review?(etienne) → review+
Thanks Etienne!

master: https://github.com/mozilla-b2g/gaia/commit/ce37025013ea1273ebb60cc49e875aebbae20e8b
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on the latest build of Aries KK v2.5 and Flame KK v2.5 by the STR in comment 0.

Actual results: Create 2 contacts on the phone with duplicate information and observe the "Duplicates found" screen, the "Merge" button is full visible.

See attachment: Verified_Aries_KK_v2.5.png

Reproduce rate: 0/10

Device: Aries KK 2.5 (Pass)
Build ID               20151008002716
Gaia Revision          b99837aa2294348317bcae68acabe71d9a83d774
Gaia Date              2015-10-07 13:04:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/c6ede6f30f3dc886543bb1c76fd7c8b5a151786b
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151007.234555
Firmware Date          Wed Oct  7 23:46:03 UTC 2015
Bootloader             s1

Device: Flame KK 2.5 (Pass)
Build ID               20151007150205
Gaia Revision          b99837aa2294348317bcae68acabe71d9a83d774
Gaia Date              2015-10-07 13:04:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/1e1fa696e2b626ead6817b7c5bd871fec5d5ab5a
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151007.183338
Firmware Date          Wed Oct  7 18:33:51 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: