receive echo mail for twice

RESOLVED INCOMPLETE

Status

MailNews Core
Networking: POP
P3
normal
RESOLVED INCOMPLETE
17 years ago
6 years ago

People

(Reporter: huzheng, Unassigned)

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
BuildID:    20011227

after use mozilla mail for some monthes, this happend for two time.
this time i can give some information about the bug
one day i receiving two new mail,one of they have a picture as a attact file. 
but it seems the speepd is slow,so i chick the stop button,and get mail 
again,the error turned out,it said there have 236 new mails. after received all 
the mail.ehco mail have two copy except that two new mails.
in my setting,i choosed "keep the mails save in the mail server". maybe "delete 
mail which have deleted locally" is also enabled.

Reproducible: Sometimes
Steps to Reproduce:
get mail,stop,get mail again

Actual Results:  ehco mail recived for twice

Expected Results:  echo mail have two copy

no

Comment 1

17 years ago
This would be a POP3 bug, then, in our handling of stop during download of new
mail, with UIDL. Navin, haven't you worked in this area before? (a long time
ago, IIRC).
Assignee: bienvenu → naving
Status: UNCONFIRMED → NEW
Component: Mail Database → Networking - POP
Ever confirmed: true

Comment 2

17 years ago
It is known issue on linux. Sometimes, we do end up getting two copies of mail. 
I think this happens only with last mail that was stopped. 
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → Future
mass re-assign.
Assignee: naving → sspitzer
Status: ASSIGNED → NEW
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: esther → networking.pop
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core

Comment 6

6 years ago
reporter address fails.
if anyone still sees this, please update the bug
Whiteboard: [closeme 2012-05-01]

Comment 7

6 years ago
Resolved per whiteboard
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2012-05-01]
You need to log in before you can comment on or make changes to this bug.