Closed Bug 1209645 Opened 4 years ago Closed 3 years ago

Show Environment Data prefs in Telemetry Dashboard.

Categories

(Data Platform and Tools :: Telemetry Dashboards (TMO), defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1336977

People

(Reporter: bwinton, Unassigned)

References

Details

We (the UX team, and possibly some Product Managers) have a pref in the "Environment Data" block that we want to look at, but there doesn't seem to be any way to get the dashboard to show it.

(Specifically, in this case, we're interested in the value of the "userPrefs.browser.urlbar.suggest.searches" pref, as split out by "userPrefs.browser.urlbar.userMadeSearchSuggestionsChoice" and channel, and possibly over time…)
Vladan, how are the SIMPLE_MEASURES_* made available?
Maybe we can make a core set of environment measures available in a similar way?
Flags: needinfo?(vladan.bugzilla)
Although that doesn't cover the use-case here (sorry, reading failure), i don't think there is a way around a custom analysis or dashboard here.
(In reply to Georg Fritzsche [:gfritzsche] from comment #1)
> Vladan, how are the SIMPLE_MEASURES_* made available?

if I understand your question correctly: the startup timings in the simpleMeasurements section are automatically converted to exponential histograms with range 0-30,000 by the aggregator, e.g. ping.payload.simpleMeasurements.firstPaint would be shown in the dash as SIMPLE_MEASURES_FIRSTPAINT

> Maybe we can make a core set of environment measures available in a similar way?

Looking at my environment.settings section in about:telemetry, most prefs are boolean but a few are strings. The boolean prefs could easily be exposed in the dash. The string prefs would need to be presented differently (X-axis: string values, Y-axis: absolute count + % share). They can't really be shoehorned into keyed count histograms.

>Although that doesn't cover the use-case here (sorry, reading failure), i don't think there is a way around a custom analysis or dashboard here.

Yes, we'll need a custom dash for the string prefs.

I have a new hire starting mid-October, this might be a decent ramp up project, but I was also considering having him help with e10s perf Telemetry or content-perf.
Flags: needinfo?(vladan.bugzilla)
Blocks: 1210637
(In reply to Vladan Djeric (:vladan) from comment #3)
> I have a new hire starting mid-October, this might be a decent ramp up
> project, but I was also considering having him help with e10s perf Telemetry
> or content-perf.

Hey! I think _I_ am that new hire!

Regardless, this is subsumed by either or both of the efforts to reshape environment data so it's easier to consume casually by adapting it on the aggregator (bug 1247618) or by reporting it more sensibly on the client (bug 1336977)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1336977
Product: Webtools → Data Platform and Tools
You need to log in before you can comment on or make changes to this bug.