Closed Bug 1209793 Opened 7 years ago Closed 7 years ago

There is a blank option in artist view of the music app

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-master verified)

VERIFIED FIXED
FxOS-S8 (02Oct)
Tracking Status
b2g-master --- verified

People

(Reporter: AdamA, Assigned: justindarc)

References

Details

(Whiteboard: [2.5-Daily-Testing][Spark][NGA Only])

Attachments

(4 files)

Attached file logcat
Description:
In the artist view of the music app there is a blank option at the top of the list of artists

Repro Steps:
1) Update a Aries to 20150929110451
2) Open the music app
3) go to the artist view
4) Observe top option

Actual:
There is a blank option in playlist view

Expected:
It is expected that all the option in a list have labels describing their content

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20150929110451
Gaia: f345f6a015709beeb2ca3955cab077fcaa959d3b
Gecko: acdb22976ff86539dc10413c5f366e1fb429a680
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Repro frequency: 10/10
See attached: Screenshot, logcat
Attached image Blank option artist
This issue DOES occur on Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
BuildID: 20150929030205
Gaia: f345f6a015709beeb2ca3955cab077fcaa959d3b
Gecko: acdb22976ff86539dc10413c5f366e1fb429a680
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 44.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Result:
There is a blank option in playlist view
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
I have seen that with some samples I have too.
Taking this. I'm gonna block on Bug 1209370 though since updates l20n.js to 3.1.0 and fixing this issue will require further use of l20n.js. This should also fix Bug 1209795 in the process. If so, I'll close that one out as a dupe when I have a patch ready.
Assignee: nobody → jdarcangelo
Status: NEW → ASSIGNED
Depends on: 1209370
Whiteboard: [2.5-Daily-Testing][Spark] → [2.5-Daily-Testing][Spark][NGA Only]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Attachment #8668577 - Flags: review?(squibblyflabbetydoo)
Comment on attachment 8668577 [details] [review]
[gaia] justindarc:bug1209793 > mozilla-b2g:master

Looks good. We might want to ask UX if we should localize the "?" though.
Attachment #8668577 - Flags: review?(squibblyflabbetydoo) → review+
Comment on attachment 8668619 [details] [review]
[gaia] hfiguiere:bug1209793-empty-album-artist > mozilla-b2g:master

the tests on top of your patch.
Attachment #8668619 - Flags: review?(jdarcangelo)
Attachment #8668619 - Flags: review?(jdarcangelo) → review+
Landed
https://github.com/mozilla-b2g/gaia/commit/9cd540e4801cfb22146b29370aa348f254c9ba5b
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S8 (02Oct)
Duplicate of this bug: 1209795
This issue is verified fixed in Aries 2.5.

Environmental Variables:
Device: Aries 2.5 [Full Flash]
BuildID: 20151008143352
Gaia: 4973f57cd8f9a62a95f783a24eac32da2bde99fc
Gecko: 1f4cf75c894862cf3634d6014d8de9c807a054a7
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Result:
the top option is "unknown artist"
Status: RESOLVED → VERIFIED
Flags: needinfo?(jmercado)
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.