Settings/Option button missing from UI on OnePlus Two

VERIFIED WORKSFORME

Status

()

Firefox for Android
General
VERIFIED WORKSFORME
2 years ago
2 years ago

People

(Reporter: ste, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8667801 [details]
Screenshot_2015-09-29-22-29-18.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20150928004020

Steps to reproduce:

Seems to be a device specific issue, Cannot replicate on other Android devices of the same version (5.1.1). (Note 4, Oneplus One, Nexus 5)

Oneplus Two is running Oxygen OS 2.1 (Android 5.1.1 ROM) (The latest stable release)

1) Installed Firefox for Android on OnePlus Two (fresh install, new device)
2) Opened Application



Actual results:

3) No sign of the Settings/Option button, just the 'Tab' button. Works fine
4) User cannot jump into the Settings/Option section.   

*screenshot attached


Expected results:

Settings/Option Button should appear on the UI.
Interesting. This almost looks like HardwareUtils.hasMenuButton() is returning true on this device.
(Reporter)

Comment 2

2 years ago
The OnePlus Two has a Volume Rocker (akin to the iPhone/iPad setup). This is the only unique hardware feature I've not seen on other Android devices.

Tested on all channels just now, same result.
(Reporter)

Updated

2 years ago
OS: Unspecified → Android
Hardware: Unspecified → ARM
https://forums.oneplus.net/threads/menu-button-issues-when-using-capacitive-buttons.370421/
Version: Firefox 41 → Trunk
Created attachment 8667893 [details]
tmp_31233-IMG_20150930_1957231229941341.jpg

It doesn't have the three dots, but if you long press the window key,it opens the options
(Reporter)

Comment 5

2 years ago
Can confirm that the long press works. Is there anyway we can include this in the UX in the future? Otherwise (like me) users will be confused at first.
I just filed bug 1209967. We are considering always showing the overflow menu - No matter what the hardware is.

Comment 7

2 years ago
Thanks Sebastian for the follow up bug. 
As this is implemented through HW Menu Button I will close this one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Updated

2 years ago
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1173209

Updated

2 years ago
Duplicate of this bug: 1226368
Duplicate of this bug: 1226752
Duplicate of this bug: 1227658
You need to log in before you can comment on or make changes to this bug.