Text cutoff in search suggestions if the text is longer than one row

RESOLVED FIXED in Firefox 44

Status

()

Firefox for Android
General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Flaviu Cos, Assigned: ally)

Tracking

Trunk
Firefox 44
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox44 verified)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Environment: 
Device: Nexus 4 (Android 5.1);
Build: Nightly 44.0a1 (2015-09-30);

Steps to reproduce:
1. Load a page (e.g.: https://en.wikipedia.org/wiki/Mozilla);
1. Copy an entire paragraph to clipboard;
2. Pate the text into the URL bar;

Expected result:
The entire text is displayed in the search suggestions.

Actual result:
Only one row is visible in the search suggestions.

Notes:
Please check the screenshot: http://i.imgur.com/FnR3tnU.png

Comment 1

3 years ago
Regression window:
2015-09-28 - Good
2015-09-29 - Bad
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6256ec9113c115141aab089c45ee69438884b680&tochange=acdb22976ff86539dc10413c5f366e1fb429a680
Bug 1205149 caused this regression
Blocks: 1205149
I bet this has something to do with the fixed height I remember being discussed.
Flags: needinfo?(ally)
Flags: needinfo?(alam)

Comment 3

3 years ago
(In reply to Mihai Pop from comment #1)
> Regression window:
> 2015-09-28 - Good
> 2015-09-29 - Bad
> Pushlog:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=6256ec9113c115141aab089c45ee69438884b680&tochange=acdb
> 22976ff86539dc10413c5f366e1fb429a680
> Bug 1205149 caused this regression

It can't be Bug 1205149, constants were moved into xml files, nothing is changed that is realted to suggestion UI

Comment 4

3 years ago
Did some research. Bug 1199335 caused this.
(Assignee)

Comment 5

3 years ago
mfinkle is correct. the pills have a fixed height. 
http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/resources/layout/suggestion_item.xml#11

:antlam, what do you want to do UX wise for searches that are whole paragraphs long?
Flags: needinfo?(ally)
I don't think we need to keep 80dp fixed. That should probably be variable.

What I do want to keep consistent is the 5dp padding above the first row of pills and below the last row of tabs.

Does that help Ally?
Flags: needinfo?(alam) → needinfo?(ally)
(Assignee)

Comment 7

3 years ago
:antlam, the 80dp height of the search row isn't the problem here, it's the height of the pill/individual search suggestion itself that is fixed and problematic here. Does that make sense?

Are you okay with the pill itself containing multiple lines of text? I don't think truncating the user's search term or suggestions will win us any points in the cases of people who are searching for something so very specific. So I'd like to make the pill height flex to contain multiple lines of text if needed
Flags: needinfo?(ally) → needinfo?(alam)
(In reply to Allison Naaktgeboren please NEEDINFO? :ally from comment #7)
> :antlam, the 80dp height of the search row isn't the problem here, it's the
> height of the pill/individual search suggestion itself that is fixed and
> problematic here. Does that make sense?
> 
> Are you okay with the pill itself containing multiple lines of text? I don't
> think truncating the user's search term or suggestions will win us any
> points in the cases of people who are searching for something so very
> specific. So I'd like to make the pill height flex to contain multiple lines
> of text if needed

Works for me!
Flags: needinfo?(alam) → needinfo?(ally)
(Assignee)

Comment 9

3 years ago
sold.
Flags: needinfo?(ally)
(Assignee)

Comment 10

3 years ago
Created attachment 8668173 [details]
device-2015-09-30-161519-no-right-margin.png

with just the pill height returned to flexible height. I think the lack of whitespace and button/pill/suggestion edge is not nice.
Assignee: nobody → ally
Status: NEW → ASSIGNED
(Assignee)

Comment 11

3 years ago
Created attachment 8668174 [details]
device-2015-09-30-161126-10dp-right-margin.png

flexible pills + a 10dp margin. I think that looks much nicer.
(Assignee)

Updated

3 years ago
Attachment #8668174 - Attachment is patch: false
(Assignee)

Updated

3 years ago
Attachment #8668174 - Attachment mime type: text/plain → image/png
(Assignee)

Comment 12

3 years ago
:antlam, I've attached two screen shots, one with an additional margin on the right and one without. I picked the 10dp number of out the air for the margin number. I think we really need a margin there. What do you think?
Flags: needinfo?(alam)
(Assignee)

Comment 13

3 years ago
Created attachment 8668176 [details] [diff] [review]
flexSearchSuggestionPills

pending :antlam's opinion of course
(In reply to Allison Naaktgeboren please NEEDINFO? :ally from comment #12)
> :antlam, I've attached two screen shots, one with an additional margin on
> the right and one without. I picked the 10dp number of out the air for the
> margin number. I think we really need a margin there. What do you think?

ah, I think you have the right idea here! Good call.

Let's stick with the 15dp that we used with the right side of the opt-in yes/no buttons in bug 1195614, thats our usual padding from the right and left sides of the screen ;)
Flags: needinfo?(alam) → needinfo?(ally)
(Assignee)

Comment 15

3 years ago
Created attachment 8668579 [details] [diff] [review]
flexSearchSuggestionPills w/15dp margin
Attachment #8668176 - Attachment is obsolete: true
Flags: needinfo?(ally)
Attachment #8668579 - Flags: review?(mark.finkle)
Comment on attachment 8668579 [details] [diff] [review]
flexSearchSuggestionPills w/15dp margin

I assume this still looks good with other, more typical, pill/suggestion sizes.
Attachment #8668579 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 17

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/21ae0d771356c908e3caae98e4e586538b5901db
Bug 1209951 - Text cutoff in search suggestions if the text is longer than one row.r=mfinkle
https://hg.mozilla.org/mozilla-central/rev/21ae0d771356
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox44: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 44
Created attachment 8669555 [details]
Screenshot_2015-10-05-11-30-20.png

Verified as fixed using:
Device: Samsung Galaxy Note 5 (Android 5.1.1)
Build: Firefox for Android 44.0a1 (2015-10-04)
status-firefox44: fixed → verified
Blocks: 1199335
No longer blocks: 1205149
You need to log in before you can comment on or make changes to this bug.