Cannot play http://www.rds.it/diretta/ if media.autoplay.enabled=false

RESOLVED DUPLICATE of bug 1382574

Status

()

Core
Audio/Video: Playback
P3
normal
RESOLVED DUPLICATE of bug 1382574
2 years ago
2 months ago

People

(Reporter: teo, Unassigned, Mentored)

Tracking

44 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(firefox50 affected, firefox51 affected, firefox52 wontfix, firefox53 affected)

Details

(Whiteboard: [bugday-20151005], URL)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150917150946

Steps to reproduce:

1. Go to about:config
2. Search for media.autoplay.enabled
3. select "false" as value
4. Close firefox
5. Open firefox again
6. Connect on "www.youtube.com"
7. Select a video
8. The "play" button indicates that the video is playing but it doesn't start
9. Trying to click on the pause button the "play" button appears, but even though you press on it the video doesn't start anyway (I tried to press a lot of times)

The only way to let the video start is to select a different point of the video (let's say you skip 4 seconds) and then come back to the beginning!


Actual results:

The only way to let the video start is to select a different point of the video (let's say you skip 4 seconds) and then come back to the beginning!


Expected results:

The "play" button should show the "play" button indicating that the video has not yet started and, however, when I press again I would like to see the video started.
(Reporter)

Updated

2 years ago
Depends on: 659285
(Reporter)

Comment 1

2 years ago
The problem is more evident here:
http://www.rds.it/diretta/

Let us know how to play the live radio ... !!!

Updated

2 years ago

Comment 2

2 years ago
Ciao Teo!

Confirming on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0 ID:20151005030206 CSet: b56aeea0c4701677ffda6417183caa60d2a6a4a7 without Flash.

Steps:
- Set media.autoplay.enabled=false in about:config
- Load http://www.rds.it/diretta/

Result:
It is not possible to play the main content.

Expected result:
Clicking the main content makes it play.

Guessing a component =)

Grazie!
Alex
Assignee: nobody → benjamin
Status: UNCONFIRMED → NEW
Component: Untriaged → Plugin Click-To-Activate Whitelist
Ever confirmed: true
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Summary: Cannot play videos if autoplay is disabled → Cannot play http://www.rds.it/diretta/ if media.autoplay.enabled=false
Version: 41 Branch → 44 Branch

Updated

2 years ago
Whiteboard: [bugday-20151005]

Comment 3

2 years ago
For what it's worth, I found two workarounds: run `jwplayer("myVideo").play();` from Scratchpad and then press the play/pause button, or load the stream directly from http://46.37.20.205:8000/rdsmp3.

The site uses (an old version of) a JS library called JW Player, which apparently doesn't handle the media.autoplay.enabled=false case well. There's also a bug in the site JS for the play/pause button: JW Player can be in one of 4 states (IDLE, PLAYING, PAUSED, or BUFFERING), but if the current state is BUFFERING then the site JS does nothing:

$('.pp_button i').on('click', function() {
  $state = jwplayer("myVideo").getState();
  if ($state == "PAUSED" || $state == "IDLE") {
    jwplayer("myVideo").play(true);
    $(this).removeClass('fa-play').addClass('fa-pause');
  } else if ($state == "PLAYING") {
    jwplayer("myVideo").stop();
    $(this).removeClass('fa-pause').addClass('fa-play');
  }
});

As it happens, JW Player loads with state=BUFFERING if autoplay is disabled.

(Oddly, running .stop() doesn't unstick the site, even though it does change the state to IDLE. I'm not quite sure what's up with that.)
(Reporter)

Comment 4

2 years ago
Another site on which the autoplay:false doesn't work in the right way:

http://www.fantastica.it/player-fantastica.html

Even though the autoplay is set to false, the player starts anyway!

Comment 5

2 years ago
I can't get that one to work at all. Maybe it's falling back on Flash?
(Reporter)

Comment 6

2 years ago
Yes, I think this is the reason: it is a flash streaming content.
When I had the old version of flash player it didn't work, too!
(Reporter)

Comment 7

2 years ago
More:
When video should run in background they are stopped but then, sometimes, it is not possible to run them when you want to play.
For example, let's look at this website

https://beeline.co/

Why don't you add a play/pause button in the tab title to let users play what your script stopped?
(Reporter)

Updated

2 years ago
Mentor: rbarker@mozilla.com

Comment 8

2 years ago
I'm sorry I didn't notice: this has nothing to do with the plugin whitelist. Moving to the correct component, but I expect that this is likely a website bug and not something that we could effectively fix in Firefox.
Assignee: benjamin → nobody
Component: Plugin Click-To-Activate Whitelist → Audio/Video: Playback
Product: Firefox → Core
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #8)
> I'm sorry I didn't notice: this has nothing to do with the plugin whitelist.
> Moving to the correct component, but I expect that this is likely a website
> bug and not something that we could effectively fix in Firefox.


A lot of these come down to media.autoplay.enabled=false not being supported by sites.
Priority: -- → P2
Mass change P2 -> P3
Priority: P2 → P3

Updated

a year ago
status-firefox50: --- → affected
status-firefox51: --- → affected
status-firefox52: --- → affected
status-firefox53: --- → affected
Mass wontfix for bugs affecting firefox 52.
status-firefox52: affected → wontfix
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1382574
You need to log in before you can comment on or make changes to this bug.