Closed Bug 1210006 Opened 7 years ago Closed 7 years ago

Show enabled/disabled state in Firefox Sync menu entry in main Settings panel

Categories

(Firefox OS Graveyard :: Sync, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1223812
2.6 S2 - 12/4

People

(Reporter: ferjm, Assigned: ferjm)

References

Details

Just like FxA and FindMyDevice does, we can show the state of Sync on the main Settings panel.
Blocks: fxos-sync
Target Milestone: --- → FxOS-S9 (16Oct)
Priority: -- → P3
Target Milestone: FxOS-S9 (16Oct) → 2.6 S2 - 12/4
Assignee: nobody → ferjmoreno
Actually, I think we can do this as part of bug 1223812.

Mark, what do you think about moving the FindMyDevice and Firefox Sync menu entries inside the Firefox Accounts panel?

FMD and Firefox Sync are fully dependent on the FxA login, you cannot be logged in any of these two services if you are not logged into FxA.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(mliang)
Resolution: --- → DUPLICATE
Duplicate of bug: 1223812
(In reply to Fernando Jiménez Moreno [:ferjm] from comment #1)
> Actually, I think we can do this as part of bug 1223812.
> 
> Mark, what do you think about moving the FindMyDevice and Firefox Sync menu
> entries inside the Firefox Accounts panel?
> 
> FMD and Firefox Sync are fully dependent on the FxA login, you cannot be
> logged in any of these two services if you are not logged into FxA.
> 
> *** This bug has been marked as a duplicate of bug 1223812 ***

Sounds right to me. Both FMD and sync will have to prompt users to login again which seems like an extra step, right?
Flags: needinfo?(mliang) → needinfo?(ferjmoreno)
No, the FxA login flow won't be shown again while enabling FMD or Sync cause the user is already logged in.
Flags: needinfo?(ferjmoreno)
You need to log in before you can comment on or make changes to this bug.