Crash in DOM Inspector [@nsOutlinerBodyFrame::SetView]

VERIFIED DUPLICATE of bug 123109

Status

()

--
critical
VERIFIED DUPLICATE of bug 123109
17 years ago
8 years ago

People

(Reporter: Biesinger, Assigned: hewitt)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Mozilla crashed when trying to inspect the XBL Bindings of <tabbrowser>.
timeless told me to 
file against trees.

Stack trace:
#0  0x41d7d691 in nsOutlinerBodyFrame::SetView 
(this=0x8a721f0, aView=0x8a1db10)
    at 
/part2/mozilla/layout/xul/base/src/outliner/src/nsOutlinerBodyFrame.cpp:639
#1  
0x41d884f5 in nsOutlinerBoxObject::SetView (this=0x8a74fc0, aView=0x8a1db10)
    at 
/part2/mozilla/layout/xul/base/src/outliner/src/nsOutlinerBoxObject.cpp:177
#2  
0x40242457 in XPTC_InvokeByIndex (that=0x8a74fc0, methodIndex=4, paramCount=1, 
params=0xbfffd9f4)
    at 
/part2/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_unixish_x86.cpp:153
#3 
 0x40b151b8 in XPCWrappedNative::CallMethod (ccx=@0xbfffdae4, mode=CALL_SETTER)
    at 
/part2/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp:1998
#4  0x40b33350 in 
XPCWrappedNative::SetAttribute (ccx=@0xbfffdae4) at 
/part2/mozilla/js/src/xpconnect/src/xpcprivate.h:1821
#5  0x40b1dd1a in 
XPC_WN_GetterSetter (cx=0x81d4980, obj=0x8a4a4e8, argc=1, argv=0x8ab7374, 
vp=0xbfffdc84)
    at 
/part2/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp:1290
#6  0x400c2d30 
in js_Invoke (cx=0x81d4980, argc=1, flags=2) at 
/part2/mozilla/js/src/jsinterp.c:832
#7  0x400c3132 in js_InternalInvoke 
(cx=0x81d4980, obj=0x8a4a4e8, fval=145007872, flags=0, argc=1, argv=0xbfffe278, 
rval=0xbfffe278)
    at /part2/mozilla/js/src/jsinterp.c:924
#8  0x400e5edf in 
js_SetProperty (cx=0x81d4980, obj=0x8a4a4e8, id=136939032, vp=0xbfffe278) at 
/part2/mozilla/js/src/jsobj.c:2689
#9  0x400cf5b1 in js_Interpret (cx=0x81d4980, 
result=0xbfffe3c0) at /part2/mozilla/js/src/jsinterp.c:2641
#10 0x400c2db2 in 
js_Invoke (cx=0x81d4980, argc=1, flags=2) at /part2/mozilla/js/src/jsinterp.c:849
#11 
0x40b0e4c7 in nsXPCWrappedJSClass::CallMethod (this=0x8365510, wrapper=0x8ab30b0, 
methodIndex=3, info=0x8211f48, 
    nativeParams=0xbfffe854) at 
/part2/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp:1201
#12 0x40b0967e in 
nsXPCWrappedJS::CallMethod (this=0x8ab30b0, methodIndex=3, info=0x8211f48, 
params=0xbfffe854)
    at 
/part2/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp:429
#13 0x402427d6 in 
PrepareAndDispatch (self=0x8ab30b0, methodIndex=3, args=0xbfffe914)
    at 
/part2/mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_unixish_x86.cpp:95
#14 
0x40242868 in nsXPTCStubBase::Stub3 (this=0x8ab30b0) at 
../../../../../../dist/include/xpcom/xptcstubsdef.inc:5
#15 0x412423a7 in 
nsEventListenerManager::HandleEventSubType (this=0x8ab30e8, 
aListenerStruct=0x8ab3180, aDOMEvent=0x8ab41c0, 
    aCurrentTarget=0x8ab257c, 
aSubType=1, aPhaseFlags=7) at 
/part2/mozilla/content/events/src/nsEventListenerManager.cpp:1205
#16 0x41244afb 
in nsEventListenerManager::HandleEvent (this=0x8ab30e8, aPresContext=0x0, 
aEvent=0xbfffed10, aDOMEvent=0xbfffecd4, 
    aCurrentTarget=0x8ab257c, aFlags=7, 
aEventStatus=0xbfffed4c) at 
/part2/mozilla/content/events/src/nsEventListenerManager.cpp:1878
#17 0x41435552 
in nsDocument::HandleDOMEvent (this=0x8ab2548, aPresContext=0x0, aEvent=0xbfffed10, 
aDOMEvent=0xbfffecd4, aFlags=1, 
    aEventStatus=0xbfffed4c) at 
/part2/mozilla/content/base/src/nsDocument.cpp:3237
#18 0x41373580 in 
nsXMLDocument::EndLoad (this=0x8ab2548) at 
/part2/mozilla/content/xml/document/src/nsXMLDocument.cpp:638
#19 0x4136934d in 
nsXMLContentSink::DidBuildModel (this=0x8ab6e80, aQualityLevel=0)
    at 
/part2/mozilla/content/xml/document/src/nsXMLContentSink.cpp:396
#20 0x408c9d13 in 
nsExpatDriver::DidBuildModel (this=0x883d698, anErrorCode=0, aNotifySink=1, 
aParser=0x8ab4278, aSink=0x8ab6e80)
    at 
/part2/mozilla/htmlparser/src/nsExpatDriver.cpp:841
#21 0x408ddfa0 in 
nsParser::DidBuildModel (this=0x8ab4278, anErrorCode=0) at 
/part2/mozilla/htmlparser/src/nsParser.cpp:1385
#22 0x408df039 in 
nsParser::ResumeParse (this=0x8ab4278, allowIteration=1, aIsFinalChunk=1, 
aCanInterrupt=1)
    at /part2/mozilla/htmlparser/src/nsParser.cpp:1892
#23 0x408e0b1f 
in nsParser::OnStopRequest (this=0x8ab4278, request=0x8ab35f0, aContext=0x0, 
status=0)
    at /part2/mozilla/htmlparser/src/nsParser.cpp:2516
#24 0x40c4939b in 
nsJARChannel::OnStopRequest (this=0x8ab35f0, jarExtractionTransport=0x8
#25 
0x40c6a274 in nsOnStopRequestEvent::HandleEvent (this=0x424006f0) at 
/part2/mozilla/netwerk/base/src/nsRequestObserverProxy.cpp:212
#26 0x40be2373 in 
nsARequestObserverEvent::HandlePLEvent (plev=0x424006f0) at 
/part2/mozilla/netwerk/base/src/nsRequestObserverProxy.cpp:115
#27 0x4021d24c in 
PL_HandleEvent (self=0x424006f0) at /part2/mozilla/xpcom/threads/plevent.c:590
#28 
0x4021d049 in PL_ProcessPendingEvents (self=0x80c1260) at 
/part2/mozilla/xpcom/threads/plevent.c:520
---Type <return> to continue, or q <return> to 
quit---
#29 0x4021f44f in nsEventQueueImpl::ProcessPendingEvents (this=0x80c1238) at 
/part2/mozilla/xpcom/threads/nsEventQueue.cpp:388
#30 0x409dada4 in 
event_processor_callback (data=0x80c1238, source=6, condition=GDK_INPUT_READ)
    at 
/part2/mozilla/widget/src/gtk/nsAppShell.cpp:184
#31 0x409da936 in 
our_gdk_io_invoke (source=0x824b448, condition=G_IO_IN, data=0x824b438) at 
/part2/mozilla/widget/src/gtk/nsAppShell.cpp:77

To reproduce:
1. Open Dom 
Inspector
2. File|Inspect a Window|Pick one
3. Click on hbox->vbox->hbox->tabbrowser
4. 
Choose XBL Bindings

Updated

17 years ago
Keywords: crash

Comment 1

17 years ago
Marking as dup since bug 123109 has more comments.

*** This bug has been marked as a duplicate of 123109 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
vrfy
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
Crash Signature: [@nsOutlinerBodyFrame::SetView]
You need to log in before you can comment on or make changes to this bug.