Software update alert with dead link to release notes

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: hanche, Unassigned)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:41.0) Gecko/20100101 Firefox/41.0
Build ID: 20150917150946

Steps to reproduce:

I am running Firefox 41.0 on OS X. It popped up an alert just now: “Update available”. The alert contains a link “View more information about this update” pointing to https://www.mozilla.org/en-US/firefox/41.0.1/releasenotes/
I clicked this link.


Actual results:

I got a “Whoops!” page (aka 404) saying the page does not exist.


Expected results:

Showing the releasnotes for 41.0.1 would have been reasonable.
I think those release notes aren't published yet.

Is that correct, Sylvestre?
Flags: needinfo?(sledru)
(Reporter)

Comment 2

3 years ago
Okay, but shouldn't the release notes be published before the release is pushed out?

I ended up not updating (yet) because the dead link made the whole thing smell fishy. Others might react the same way.
Duplicate of this bug: 1210141

Comment 4

3 years ago
The release notes are now live for 41.0.1. I apologize the slight delay in publishing them.
Flags: needinfo?(sledru)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.